How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Andy Your Own Question
Andy
Andy, Truck Diagnostic Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 1571
Experience:  International trucks, International, Maxxforce and Cummins engines, diagnostic, electrical, Hvac and refrigeration repairs
30303843
Type Your Medium and Heavy Trucks Question Here...
Andy is online now
A new question is answered every 9 seconds

The lift pump is not functioning and I can't detect any power

Customer Question

The lift pump is not functioning and I can't detect any power going to it. The truck was running fine and started ok without the lift pump functioning. I turned it off now and it will not fire. There is power going too the solenoid, but how can I tell if it is working or opening.
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Andy replied 1 year ago.
Hi my name is Andy !Can we start with the engine serial number please ? Also , do you have an engine lamp staying on ?
Customer: replied 1 year ago.
Hi Andy. The engine ser# *****(###) ###-#### ***** put power to the lift pump and it pumped but still nothing. There is power to the fuel shutoff solenoid but when I disconnected it and touched it to the connection terminal there is no arc or any noise that comes from the solenoid.Andy there is a yellow check engine light that has been on for some time but when I read the active codes yesterday they related to abs and low voltage on engine fan. Nothing in the severe area
Expert:  Andy replied 1 year ago.
That is not the engine serial number! It should be 8 digits long.
Customer: replied 1 year ago.
ESN 79392259
Expert:  Andy replied 1 year ago.
Thanks
Expert:  Andy replied 1 year ago.
Did you read the codes using Insite ?
Expert:  Andy replied 1 year ago.
Please turn the key off for one minute . Go to the lift pump 2 wire electrical connector and disconnect it . Then , hook up a small headlamp or small work lamp to the connector and have someone turn the key on . It should light the headlamp . Let me know . Thanks
Customer: replied 1 year ago.
There is no power at the two wire plug with the key on. I supplied a 12 volt power source to the pump and it functions fine, it pumped almost immediately but the truck still would not fire. There is power at the fuel shutoff solenoid but I can't determine if it is functioning properly.
Expert:  Andy replied 1 year ago.
Ok Can you please give me the code numbers you had in engine ECM memory ? Also , when you turn the key on , does the check engine turn on for a few seconds and got out ? This tells us if the ECM is powering up !
Customer: replied 1 year ago.
I left the truck again with the print out inside it. I don't plan on going back today. The check engine light stays on as it has for the last month.
Expert:  Andy replied 1 year ago.
Ok ! I have a feeling the problem will be in your Engine harness ( the red one) going to the ECM . This one has the wiring for lift pump , shutoff solenoid , etc.. . I would take a good look at the wiring harness for rubouts or loose wiring or damage .
Expert:  Andy replied 1 year ago.
And if you can get me the faults in memory , that would help as I could get you the troubleshooting for those to help narrow down where the problem .