How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 1732
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

Clayton. I have a 2006 Columbia 120 w/ Mercedes 4000. About

Customer Question

Hi Clayton. I have a 2006 Columbia 120 w/ Mercedes 4000. About a 2 yrs ago I had an overhead done and replaced the EGR valve. It run very well after that. It sat after that until now. Check engine light come on almost immediately after sitting that long. Power was way down. Pulled 2 loads with it but it was a struggle. After using the engine brake just recently there is no power alot of black smoke coming out of the exhaust. trouble codes are all Turbo function. Truck starts fine and idles fine. No unusual noise coming from turbo. Your thoughts? Thanks
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Customer: replied 1 year ago.
Received a 103 code from the dash readout
Expert:  Jeremy replied 1 year ago.
My name is ***** ***** I will assist you. I see this has been sitting awhile. Did you still need help with this one? __________________________________________________________________________________________________________________________You want a 5 star service and I want to provide a 5 star service. Please consider that I don't know your skill level as well as I can't see,touch, smell, hear, or taste the vehicle/machine in question. Please provide as much detail as possible and I will provide as much back.The system DOES NOT automatically give me credit from your deposit. A rating is REQUIRED. You are rating me for the information I provide,not the website. I have no control over the site fees, site errors, category errors, or how long it took for a response for these reasons.I am not an employee of this website, so please rate with a POSITIVE (green) rating for me to get credit for assisting you. You still paythe website for negatives or by not rating at all. I just get nothing from that payment you made. So please rate each answer I provide.I want you pleased with my service to you so please inform me before rating negative (red) and I will do my best to make it right. Followups for same question are always free after ratings have been made.I do have many workshop manuals, diagrams, etc that I pay to get access to out of my pocket. If one is needed, please ask and I will giveyou an offer at my technician discounted cost to you for such manuals. I never charge above that cost.Thank you for allowing me to assist you through Just Answer!Jeremy