How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask roybelding Your Own Question
roybelding
roybelding, Shop Foreman Freightliner trucks
Category: Medium and Heavy Trucks
Satisfied Customers: 4657
Experience:  Shop Froeman for Freightliner Trucks
3506196
Type Your Medium and Heavy Trucks Question Here...
roybelding is online now
A new question is answered every 9 seconds

111mk, i have a 2010 century with a DD15 the truck leaks

Customer Question

hello i have a 2010 century with a DD15 the truck leaks diesel from exhaust i believe its coming from injector dozer and its seems to do it only at certain temps while running it seems to inject a lot more and when i hooked up the computer my outlet temperature
sensors where higher than 400F
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  roybelding replied 1 year ago.
good afternoon my name is ***** ***** I will assist
the doser injector may very well be your failure. if it leaks into the exhaust, it will heat up the sensors.
how did you determine it is the doser??? does it leak externally???
is the truck in re gen mode???
Roy
Customer: replied 1 year ago.
I already replaced the dozer and still same issue and I notice when I drive i on the mirror I can see it at first I thought it was a shut off vavle but it's not and when I do the regen it leaks from some of the exhaust clamps but no it's not on regen mode but the high temperature light does come one when driving as well and i belive it's while it's injecting on the dozer I have the truck currently Runing with a cap on the dozer line and every time it comes in I manually do a regen and hook up line to dozer I haven't been able to find the problems and I have 0 fault codes
Expert:  roybelding replied 1 year ago.
ok, it could be the doser block at the back of the block on the drivers side. it is strange that there is no codes. if the acm was bad, it should code and if there was a wiring issue, there should be voltage high and low codes.
what kind of program are you using to check codes???
Roy
Customer: replied 1 year ago.
Is the dozer block the one with the 5 sensors on top of fuel pump?? And I have 7.11 version something like that..
Expert:  roybelding replied 1 year ago.
yes, that is correct.
7.1 is an old version. we use 8.1 inspect the harness very closely for any chaffing or damage to the harness. engine sensor harness are common failures.
Roy
Customer: replied 1 year ago.
It's a brand new harness both MCM and injector harness I rebuilt the engine about 5 months ago but everything was working fine before
Expert:  roybelding replied 1 year ago.
then I would be looking at the doser block.
was there any inactive codes in the acm??
Roy
Customer: replied 1 year ago.
Yea but nothing to do with fuel system or regen just a coolant and the fan clutch vavle do I just replace the block?? Any test I can do to make sure it's that ?
Expert:  roybelding replied 1 year ago.
I would go to instrumentations and look at the actions of the sensors in the block to see if they are commanding the doser to dose. if they are, then the acm may be the failure. if not then the block itself may be the failure
Roy
Customer: replied 1 year ago.
The ACM is the on inside the cab?
Expert:  roybelding replied 1 year ago.
no, outside the drivers side in front of the batteries down low under a cover with 2 13mm bolts covering the acm
Roy
Customer: replied 1 year ago.
This is on a century Freightliner are you sure it's there can you send me similar pic of it
Expert:  roybelding replied 1 year ago.
it is at the left front. I dont have a exact picture to send but the location is either at the frame rail or in front of the batteries by the step.
Roy
Customer: replied 1 year ago.
I tried to call Freightliner to get price and don't seem to know what an ACM is
Expert:  roybelding replied 1 year ago.
that does not make sense. ask for the parts manager and let them help you. once you buy a new one, they will have to program it.
Roy
Expert:  roybelding replied 1 year ago.
how are you making out??
Roy
Customer: replied 1 year ago.
I just got truck in now will search for it
Expert:  roybelding replied 1 year ago.
please do not forget to rate me as it is the only way we get paid for our efforts.
Roy
Customer: replied 1 year ago.
I have I it here now and I don't seem to find the ACm not this is on a century with batteries are in back center of the cab
Expert:  roybelding replied 1 year ago.
what are the last 6 of the vin??
Customer: replied 1 year ago.
an2030

Related Medium and Heavy Trucks Questions