How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4731
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

Kw t800: We have a 2012 kw with a paccar motor mx10 vin # *****

Customer Question

We have a 2012 kw with a paccar motor mx10 vin # ***** it has lost boost 1 a day, the rest of the time it runs great, it has had a ecm update - def system cleaned - turbo opened up and inspected and the vgt reset - it has for the last 6 months regenerated more often tan it had before - no codes have been set in the ecm other than a water in fuel code and a new sensor was installed for that - it does do a far amount of idling - it has 52894 miles not sure on the hours - fuel pressure stays the same even the boost is lost
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 1 year ago.
Hi my name is***** will be glad to help. It seems you have covered the most common potential causes of this but just to be sure and since there are no fault codes to help, check for excessive soot buildup in the catylist, differential pressure tubes, sensor tips, etc. Check for exhaust restrictions resulting from excessive soot buildup from in the past. Long idle periods are not good. Copy and paste this link in your browser for some technical information that will explain further.
http://partsandservice.kenworth.com/pdf/MX_Maintenance_Recommendations_Paccar_MX_Engine_REVJ.PDF

Related Medium and Heavy Trucks Questions