How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cat Man Your Own Question
Cat Man
Cat Man, Cat Engine Expert
Category: Medium and Heavy Trucks
Satisfied Customers: 8727
Experience:  I am ASE Master Truck Certified.
30708357
Type Your Medium and Heavy Trucks Question Here...
Cat Man is online now
A new question is answered every 9 seconds

3406b: I have a cat 3406b and the jake brakes are not working

Customer Question

I have a cat 3406b and the jake brakes are not working they are getting 12v from the switch and the actuators are moving when powered but the jakes are not working any ideas
Submitted: 2 years ago.
Category: Medium and Heavy Trucks
Expert:  Cat Man replied 2 years ago.
Hi. Thanks for asking your question! I will try and help you out.
Did they just stop working all of a sudden?
Or was there something done to the engine recently then they stopped working?
Customer: replied 2 years ago.
Ya we overhauled the engine they worked before but after the over haul they don't work
Expert:  Cat Man replied 2 years ago.
I see. Thanks for the information.
Since you are getting power to them and you can see them moving. I would first suspect the adjustment is off. I would try resetting them. See below for the settings.
346B 0.070
346C 0.080
346D 0.067
Please reply back if you need more help. I am happy to assist.
Customer: replied 2 years ago.
Just reset the jake brake and they are still not working
Expert:  Cat Man replied 2 years ago.
If they are adjusted correctly and they are getting power. Then i would next suspect an oil supply problem. If there is oil. Then the jakes must be defective
Customer: replied 2 years ago.
There is oil that squirts out from under the little alumiun plates when in turn the switch on and off from the cab also I noticed that the jakes must of got switched when we put it back together the one that says rear is on the front and the front one is on the rear
Expert:  Cat Man replied 2 years ago.

Oh I see.

Yes if they are switched that can cause them not to work. Switching them back should help them to work.

Related Medium and Heavy Trucks Questions