How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Automotive Mechanic
Category: Medium and Heavy Trucks
Satisfied Customers: 24707
Experience:  Performed various automotive repairs on several light duty and medium duty vehicles over 15 years of service.
14928985
Type Your Medium and Heavy Trucks Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 2001 AT545 tranny just rebuilt. I was able to do 75

Customer Question

I have a 2001 AT545 tranny just rebuilt. I was able to do 75 miles an hour not loaded if i needed but now can only do about 60. The shop says the throttle body is only opening 55% at full throttle, it probably wasn't before. Any possibility of something in the valve body from last friday till today ??
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Customer: replied 1 year ago.
It supposedly has a rebuilt torque conveter and fully gone through. It burnt up 4th gear disks and found some filings when they dropped the pan. Shifts good and takes off fast in 1,2 & 3rd gear (empty) but then just dies off
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
My info is limited on your model here but I see no one else has responded and thought I would see if I can help here.
If they had disconnected the battery the computer may have lost its programming/calibration for the throttle body itself.I have seen this occur before and usually a scan tool/computer that will plug in and communicate with your models computers is needed to recalibrate the throttle body to correct this here.If this was not checked to see if this needs done I would start with this to see if this corrects the fault here.
Thanks Pete
Customer: replied 1 year ago.
On the model AT545 there's only sensors for speed, pump pressure, reverse and the modulator valve. But yes the battery has been disconnected during testing.
Expert:  Pete replied 1 year ago.
I apologize for the delay as I was off line the last few days.
If this model uses the electronic accelerator pedal and electronic throttle body I have seen the accelerator pedal act up and cause the throttle to only open a small amount and not at full throttle as it should without setting a fault code in some cases.If this has not been checked this needs done to see if this is the cause here.I have also seen the throttle position sensor on the throttle body cause this issue but usually if this was the case a fault code would set.I would have these checked to see if this is the cause for the acceleration and power issue here.
Thanks Pete

Related Medium and Heavy Trucks Questions