How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Andy Your Own Question
Andy
Andy, Truck Diagnostic Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 1571
Experience:  International trucks, International, Maxxforce and Cummins engines, diagnostic, electrical, Hvac and refrigeration repairs
30303843
Type Your Medium and Heavy Trucks Question Here...
Andy is online now
A new question is answered every 9 seconds

International prostar: . My name is***** have problem

Customer Question

Hi. My name is***** have problem with truck International Prostar 2010. I do not have any codes but truck is not doing regen. I clean DPF and change DPF sensors but still no luck.
thank you
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Customer: replied 1 year ago.
DPF is cleaned few days ago. Problem is it is doing regen but not every time. when we connect with computer sometimes it do the regen and sometimes it does not.I changed sensors on DPF but still no luck. thank you
Customer: replied 1 year ago.
first two sensors reach around 750 F but injector is not turning on. it is always off on computer screen. injector is also cleaned. so problem is with reaching right temperature and constant working/ not from time to time
Customer: replied 1 year ago.
it is cummis - isx engine
Expert:  Jeremy replied 1 year ago.
My name is ***** ***** I will assist you with your concerns.
What does the turbo pressure show when you are trying to do the regen? What are the temps showing for the inlet and pre-filter? At 750 degrees, you are getting fueling from the doser, but my concern is another extremely common issue with these engines where the turbo actuator goes out and doesn't give the engine full boosting during the regen and causes the temp to be too low. Do you have any history on the Insite showing the turbo actuator having a code at all?
Customer: replied 1 year ago.
We just finish regen. It went ON on 750 F and after few minutes went off and back to 430 F. After all cycle he didnt go above 500 F all 3 sensors, but now he gave me Code that sensor number two is bad.
Customer: replied 1 year ago.
2742 fault code. Thank you
Customer: replied 1 year ago.
There is no history with codes for turbo actuator..
Expert:  Andy replied 1 year ago.
Hi there ! Sorry to hear you are having trouble! My name is ***** ***** I would like to try and help if I can ! I see your question has been sitting for awhile and came back up in the open list ! Here is the description of the fault you now have :
https://www.dropbox.com/s/d3qzqy53c1x6w1c/2742%201.pdf?dl=0
And here is the diagnostic steps to repair this issue :
https://www.dropbox.com/s/4klaar9acefs213/2742%202.pdf?dl=0
Let me know if I can be of any further assistance . Please do not forgte to rate my service to you only at the end of this session . That is how I am rewarded on here . Thank you .

Related Medium and Heavy Trucks Questions