How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne, Journeyman
Category: Medium and Heavy Trucks
Satisfied Customers: 8284
Experience:  worked on, Gmc, Macks, Freight liner,Mercedes Benz,,Ford, sterling
Type Your Medium and Heavy Trucks Question Here...
Wayne is online now
A new question is answered every 9 seconds

hi i have a 97 international 4700 series truck with the t444e

Resolved Question:

hi i have a 97 international 4700 series truck with the t444e engine. when i try to start the truck it just cranks over for a while and after about 30 seconds (sometimes) it fires a couple times then stops and will still crank over good but wont fire. it does run on either (starting fluid) but wont run on its own now. i have changed the cam sensor and fuel filter and cleaned out the pre fuel screen and the fuel system does have around 45 psi at the shrader valve on the top of the engine near the fuel filter. we did swap the computer on the problem truck that is located on the passenger side of the engine with another truck that we have and it started up just fine in the other (good) truck. do you know what could be causing this no start condition?
Submitted: 4 years ago.
Category: Medium and Heavy Trucks
Expert:  Wayne replied 4 years ago.
Hi I'm Wayne,
I will help you with this

Fuel pressure is good,
This sounds like your High pressure oil pump, is failing
not firing injectors
You need between 1700-1900 PSI to fire injectors
If this is OEM, HPOP, replace it
Customer: replied 4 years ago.
What about the icp sensor or the ipr valve? Could they be causing this?
Expert:  Wayne replied 4 years ago.
Morning ,

Not really, possible the IPR valve,
but i believe the HPOP

Wayne and other Medium and Heavy Trucks Specialists are ready to help you
Customer: replied 4 years ago.
We got it figured out we tried the icp sensor because it was the cheapest and also because the HPOP is pretty expensive and changing the icp fixed it. After we changed it, it started right up... Just to let you know. But thanks for the help though.
Expert:  Wayne replied 4 years ago.
Thank You


Related Medium and Heavy Trucks Questions