How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Mazda
Satisfied Customers: 22301
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Mazda Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

1993 protege runs fine when cold then starts to stumble.

Customer Question

1993 protege runs fine when cold then starts to stumble. Hard to start when warm.
JA: Will the headlights turn on? Is the battery fully charged?
Customer: Yes
JA: Are you fixing your Protege yourself? What have you tried so far?
Customer: Local shop replaced,plugs, ign wires, cap, air filter, fuel filter a $500 tune up still same problem.
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 5 months ago.
Category: Mazda
Expert:  sprinkles08 replied 5 months ago.

Hello and welcome to JustAnswer!

There are quite a few things that could cause the engine to run poorly and it will take some testing to determine what is going on. If it runs fine initially when cold then one of the first things that comes to mind is an inaccurate upstream oxygen sensor, it's signal is ignored when the engine is cold.

Have you checked for fault codes?