How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Drew Your Own Question
Drew
Drew, Super Mazda Tech.
Category: Mazda
Satisfied Customers: 2188
Experience:  19 yrs. experience. Mazda Senior Certified Tech, with Ford, Linc. & Merc. experience. ASE L1 Advanced Certified Master Tech.
49548721
Type Your Mazda Question Here...
Drew is online now
A new question is answered every 9 seconds

2004 Mazda 6, 80,000 mi, used, fine 3 months. Wife got gas,

Customer Question

2004 Mazda 6, 80,000 mi, used, fine 3 months.
Wife got gas, CEL on, assumed cap loose, reset via Neg Bat off 1 minute. Fine.
2 days after:
Fine above 20 mph or highway. Surges at stops, idle rpms fluctuate(###) ###-#### CEL ON (not flashing)
Day Later:
Cold start CEL ON, in 3 blocks, eng died, (CEL flashed 3-4x & stopped flashing, but on.)
Restarted, went 3 blocks home. Begged OBD II, bought plugs.
OBD says P0300 - Random Misfire.
Further indicates BOTH Bank 1 & 2 stuck, lean.
See nothing else amiss. No unusual engine washing or dust storms. Plastics seem firmly intact to MAF.
Decent mechanic, past era. Sounds like air flow thought-limited so gas being computor-limited.
Submitted: 2 months ago.
Category: Mazda
Expert:  peterpete190 replied 2 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Have you tested fuel pressure at all to see what the fuel pressure reads on a test gauge with the no start issue now?

Let me know so we can continue,thanks Pete

Related Mazda Questions