How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Mazda
Satisfied Customers: 43882
Experience:  16 years of experience
Type Your Mazda Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

Having a problem with idle

Customer Question

hey, having a problem with idle
Submitted: 2 months ago.
Category: Mazda
Expert:  Chris (aka- Moose) replied 2 months ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.

Is the idle high, low, going up and down?

Customer: replied 2 months ago.
ok here's the scoop.
I bought the car because it had engine troubles. When cold it would surge up to 3krpm until it warmed up after a couple min and it burned oil like crazy too. I though ok intake gasket leak and valve seals. Ended up doing whole rebuild. Piston rings lapped the valves cleaned everything. put back together and surging still exists a little bit but not like before. Also found it had wrong spark plugs all along. idle is a little rough now. when it gets upto temp it will idle ok and them 10 sec later will drop to 650 ish and almost stall out. getting random misfire code. injectors, coils, wires, all new. cleaned egr and was not sticking to begin with. intake tube, iac and maf were changed before i bought. once it starts mis-firing at the low rpm it takes a little bit for it to kick back in
Customer: replied 2 months ago.
let me know if all that even makes sense lol
Expert:  Chris (aka- Moose) replied 2 months ago.

Is this misfire at idle or while driving?

If you hold the throttle at 1000 rpms with throttle pressure can you prevent the misfire or idle fluctuations?

Customer: replied 2 months ago.
starts at idle continues for a few seconds under throttle the goes away. It could be vac related but not sure. there might be something missing from this solinoid but have no idea what it is. (see attached) i tried plugging it but no difference
Customer: replied 2 months ago.
found what that is. EGR Vacuum Solenoid Switch Valve
thats prob whats causing it. but where does that connect to?
Expert:  Chris (aka- Moose) replied 2 months ago.

While running if you plug this valve by hand is there vacuum on it?

If you remove the the vacuum line and plug it does it run better?

Customer: replied 2 months ago.
i had it plugged with duct tape for few days and 0 difference. no i does not feel like any vac
Expert:  Chris (aka- Moose) replied 2 months ago.

While running, spray short bursts of flammable brake cleaner all around the intake and vacuum hoses to see if you find a vacuum leak. If you spray a leak the idle speed will change. Let me know those results.

This is my 1st answer, but does not have to be my only answer. You the website and myself expect you to have a great experience with my help. Please let me know if you are pleased by selecting a star rating above or by replying and saying your pleased. Not rating or rating 1-2 stars does not benefit you nor me in any way. Follow up and reply as often and when needed, there is no extra charge to do so.

Thanks Moose.

Expert:  Chris (aka- Moose) replied 2 months ago.

Hello again Chris here,

  • I am following up with you to see if you got everything you needed from my answer. We're you pleased with my help?
  • If you were not pleased with my help, please let me know by replying so I can help more.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I may never know it.)

Thanks Chris

Customer: replied 2 months ago.
I went to the junk yard and got the proper cap for that opening. Still drops idle after sitting for few sec. I tried your method and found no leaks at all. Im thinking maybe plugged fuel filter?
Expert:  Chris (aka- Moose) replied 2 months ago.

Has the fuel filter not been serviced regularly every 30k?

Is the fuel pressure low?

Customer: replied 2 months ago.
I dont know the history i recently bought the car. How do i test fuel pressure?
Expert:  Chris (aka- Moose) replied 2 months ago.

To test the pressure you connect a pressure gauge to the fuel supply on the injector rail.

Customer: replied 2 months ago.
What should the pressure be?
Expert:  Chris (aka- Moose) replied 2 months ago.

30-37 psi

Customer: replied 1 month ago.
ok it was a little low so i changed the pump assembly and filter. Its still the same.
Could it be plugged catalytic converter? If so would it be more likely the front or rear one?
Expert:  Chris (aka- Moose) replied 1 month ago.

You can remove the upstream O2 sensor and take the vehicle for a drive to see if it runs better with another exhaust exit.

Customer: replied 1 month ago.
ok ill try that tomorrow thanks
Expert:  Chris (aka- Moose) replied 1 month ago.

Your welcome

Related Mazda Questions