How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Mazda
Satisfied Customers: 35047
Experience:  35 years as a automotive tech
7276279
Type Your Mazda Question Here...
Ron is online now
A new question is answered every 9 seconds

91 mazda miata 1.6 (jm1na351xm1222325) no start condition

Customer Question

91 mazda miata 1.6 (jm1na351xm1222325) no start condition .there is spark . no injector pulse. on both sides of the fuel injector connector there is power ! there is battery voltage on almost all grounds .
using a dvom on a ground wire with key on the on position i have battery voltage i disconnect the fuel injector relay and drops down to 1.5 volts , i remove the BTN fuse all ground go back to normal but i dont have power on fuel injector relay ....
Submitted: 9 months ago.
Category: Mazda
Expert:  Ron replied 9 months ago.

Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here. One common cause for the lack of spark as well as injector pulse can be caused by a failing crank angle sensor so the place to start is with checking it. See the steps to do this in the link below.

https://dl.dropboxusercontent.com/u/104923897/So%20spark%20Aug%209.pdf

Customer: replied 9 months ago.
i done this step already i have battery power on most grounds including ecm grounds
Expert:  Ron replied 9 months ago.

Okay well something is being overlooked here if it passes the tests steps. This is all I have so Ill open the post back up for you.

Customer: replied 9 months ago.
okay car does not start there is spark but no injector pulse .on the injector connector there is battery voltage on both wires . when i check other grounds there is battery voltage as well . when i unplug the btn fuse all the grounds return to normal but i lost power to injector relay .