How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gary Your Own Question
Gary, ASE Certified Technician
Category: Mazda
Satisfied Customers: 683
Experience:  Senior Technician
Type Your Mazda Question Here...
Gary is online now
A new question is answered every 9 seconds

My 1999 Mazda 323 protege 1.6 has quite a bad miss when you

Customer Question

My 1999 Mazda 323 protege 1.6 has quite a bad miss when you accelerate i have teplace the plugs leads and ignition coils and nothing has changed i have also checked the filter in the tank that appeared to be fine
JA: How old is the transmission? Have you checked the fuel filters?
Customer: Transmissiion same age as the car i guess and the fuel filter is fine
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Replaced the plugs ignition leads and the ignition coils
JA: Anything else you think the mechanic should know?
Customer: It just has a fairly bad miss when you try to accelerate
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Mazda Mechanic about your situation and then connect you two.
Submitted: 4 months ago.
Category: Mazda
Expert:  Gary replied 4 months ago.

Hi there,

The next thing to do would be verify fuel pressure under load (when you accelerate).

if the pressure is ok, I would have the fuel injectors removed for an off-car injector clean.


Expert:  Gary replied 3 months ago.

Hello again,

Do you need any further help?

I hope my advice has been of assistance to you.

Kind regards


Related Mazda Questions