How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190, Auto Technician
Category: Mazda
Satisfied Customers: 24140
Experience:  Auto repair Technician with 17 years experience.Past ASE and other certifications.
Type Your Mazda Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

Im working on a 2003 Mazda 6 3.0L .Car has intermitent

Customer Question

Hi Im working on a 2003 Mazda 6 3.0L .Car has intermitent misfire.My scan tool is a Snap-on Modis updated to 2008. Car has intermitent misfire and it throws no misfire code and scan tool tool has no misfire data perimeters.prior to this it used to show specific cylinder misfire.example code p301 cylinder#1.Car sometimes has trouble communicating wth scanner I.e. test aborted.I have replaced Mass air flow sensor and replaced all 6 coils and no difference.Car has intermitent Uoo73 and Uo100 codes.Also all dash warning lights antilock overdrive check engine and basically all warning lights come on when it acts up. sometimes it runs good and as it warms up it starts misfire.a while back I also replaced throttle body which threw code when it malfunctioned. I checked all grounds and cleaned them and inspected an tested all fuses relays and wiring and now I suspect PCM/ECM and have found company ON Ebay that refurbishes them given description of problems and It is a plug and play deal. PLEASE give me your opinion ,I am ase certified L1-8 but I dont specialize in 2003 Mazda 6 .THanks for any help Don Hoemmelmeyer
Submitted: 7 months ago.
Category: Mazda
Expert:  peterpete190 replied 7 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

From what you have described here this sounds like a possible fault in the PCM itself.If you know for sure it is misfiring and the PCM is not setting codes and you have communication issues with the scan tool intermittently as well as the U codes this can be the PCM itself at fault.The U0100 code is usually a loss communication with the PCM.I would make sure all wiring and connections to the PCM are all o.k. and if o.k. as well as all fuses most likely it needs replaced.

If you have found a company that can rebuild it then no programming will be needed but if it is replaced all together it will need programmed and usually by a dealer.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete