How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask mike switzer Your Own Question
mike switzer
mike switzer,
Category: Mazda
Satisfied Customers: 611
Experience:  lead diagnostic tech at Aamco
93239347
Type Your Mazda Question Here...
mike switzer is online now
A new question is answered every 9 seconds

I have an 04 RX-8. Several symptoms which I think are

Customer Question

I have an 04 RX-8. Several symptoms which I think are interrelated. I never get a door ajar light with any door open, ever. It does not respond to any door, hood, etc being opened. I also do not get a warning beep when leaving the lights on and the key in the ignition and opening the drivers door. I also never get the ignition light (lights up the key slot) to light up, which also requires the drivers door in that circuit. All other warning lights seem to otherwise work fine. And finally I have no keyless entry ability/key fobs don't work. But the key fobs are not the issue. When I attempt to do the key recognition procedure with the car (turn key, open door on off 3 times, the door should lock unlock letting you know your in the right mode – and I’ve done it before, I know how to do it) that doesn't even happen - the door does not lock/unlock so I can't reprogram the fobs and I have to use the manual key instead.
So I was hoping all those symptoms were due to the driver door jamb (open/closed) switch, however I bench tested it and it is fine. And since I never get a door ajar light, I’m assuming every door switch on the car is not broken, so I assume they are not the problem but something more generally with a door switch circuit that is limiting those other functions. The locks work manually and with the lock/unlock switch on the door.
This has been going on for awhile now, just getting around to it now, but I’m pretty sure these are all related and happened around the same time. But I don’t know where the specific culprit would be. My best guess is the keyless control module? However the security alarm system works, the car interior light illumination system works with the key opening and closing doors and removing from ignition, and from door push button lock/unlock, just not from the doors being open or closed) and the hazard lights light up with locking/unlocking the car with the key and arming the car, suggesting it otherwise seems to be working. So I’m at a bit of a loss. If it is the keyless control module, can I replace it? I understand the car will not run without it and/or the car has to be synched to a new one or something to that effect. Need to know how and where to troubleshoot. Thanks.
Submitted: 1 year ago.
Category: Mazda
Expert:  peterpete190 replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

If you have anything after market wired in like an after market alarm system or after market remote start system this may be interfering with these components operating properly.I have seen this before and had to remove the after market components and wire the vehicle back to factory to correct this here.If this is all o.k. and no after market component wired in let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 1 year ago.
No they're no aftermarket parts. Nothing was altered, it just started happening.
Expert:  peterpete190 replied 1 year ago.

Have you had the fault codes checked using a scan tool plugged into your vehicle that can communicate with all computers in your model here?

Customer: replied 1 year ago.
P2135 and p0638, involve the throttle body. Was getting a once every few weeks check engine light, seems to have resolved with a throttle body and maf cleaning. Those are the only codes.
Expert:  peterpete190 replied 1 year ago.

Have the codes come back at all after cleaning the throttle body and mass air flow sensor?

Customer: replied 1 year ago.
No i haven't got any codes since the cleaning.
Expert:  peterpete190 replied 1 year ago.

O.k.,this is a difficult one for me to fully diagnose myself from here.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete

Customer: replied 1 year ago.
Haven't heard back from anyone, so I'm replying. I ran this 'diagnostic check' below. Seems like all other instruments are working, except the 'door ajar' warning light doesn't light with the 04 test nor does it switch from off to on when operating the door switch or opening/closing the driver door during that test. It also doesnt light during the 26 test while most all the other lights do (though not all, such as the bright light indicator, immobilizer lock light, even though they definitely work. I would think the door ajar light would be one that does light up during this test, not sure if it is supposed to). It also just indicates 'off' and does not switch to on when opening or closing either door. And finally the key illumination light test passes test 18 and lights up, and the buzzer passes 14 and buzzes, so they are working, though they never light up or buzz with my door ajar as mentioned in my first post above. (By the way the trunk and hood switches seem to operate properly, I can verify via the alarm arming when I purposely leave the trunk or hood open, close the doors and lock them manually and then close the hood or trunk)So I still think the door switch circuit is giving bad info/never indicating the door is open. Looking at other posts I see a lot of problems with the door ajar light not going out, but none with my problem of never coming on. The passenger side door lock solenoid seems to get stuck once in awhile i.e. the door won't fully lock / unlock with the lock switch, but most of the time it works fine. Doubt that has anything to do with this.Is the door ajar light suppose to come on with putting the key in the ignition in the on position for a few seconds like most of the warning lights (it doesnt for me) ? If so that might simply mean my LED warning light isn't working, but that shouldn't disable the other features that are obviously not working, would it? I'd like to at least clean some electrical connectors, maybe that is the issue? Can you guide me where to start? Can I unplug the connectors to the key control module, clean them and reconnect without having to get my keys resynched, etc? ThanksInstrument Cluster:
1. Put the key in the ignition
2. Push and hold the odometer button
3. Turn the key to the ‘ON’ position (do not start the car)
4. Continue to hold the odometer button until ‘test’ appears in the lower right corner
5. Once ‘test’ appears, you can release the button
6. Now push (not hold) the odometer button to scroll through various numbered options
7. Stop when you reach the desired output
8. After a full second the output signal should toggle (ex: light illuminates, gauge sweeps)
* Some have an on/off switch (ex: Buckle switch changes state when the seat belt is buckled)
9. To exit from the output diagnostic, simply turn the key to the ‘off’ position and back on.
Here is a list of all the outputs and what they mean:
01 = Buckle switch
04 = Door switch
08 = TNS relay
12 = Speedometer
13 = Tachometer
14 = Buzzer
16 = Fuel-level warning light
18 = Ignition key illumination
22 = Fuel gauge sender unit
23 = Fuel gauge
25 = Water temperature gauge
26 = Odometer tripmeter, warning and indicator light
28 = Oil pressure gauge
31 = Key reminder switch
55 = Dimmer switch
Customer: replied 1 year ago.
By the way the reason I care about all this is because I'd like to be able to use my remote key fobs, I don't really care about the door ajar light :)
Customer: replied 1 year ago.
I still haven't heard back on this, please provide some feedback. FYI looks like every other light works/lights up when starting the car up, seems like a sole 'door never open' sensing problem causing my troubles.
Customer: replied 1 year ago.
I'm not getting any responses here at all ??
Expert:  mike switzer replied 1 year ago.

how is it going my name is ***** ***** try my best to walk you through a few different things on this car to help you further diagnos your vehicle. i started out working at a rotary specifc shop and have a good amount of experience with rx8's

Expert:  mike switzer replied 1 year ago.

dou you have a digital volt meter handy and a few basic tools?

Customer: replied 1 year ago.
Sure do
Expert:  mike switzer replied 1 year ago.

on each door seem on the body side there is a small plunger switch which of course is the sensor for the door. if you take a 10mm i believe if memory serves you can pull iit out and check continuity of each on. i cant remember if when the door is open or if its close when it will show an open circuit. but as long as it switches between open and closed that will show each one is working.

Customer: replied 1 year ago.
Just tested. They both are a closed circuit when not pressed and open circuit when pressed
Expert:  mike switzer replied 1 year ago.

just to clarify you said the door locks work with the switch and the interior lights come on when you open the door? just the doors wont lock or unlock with the key fob? thats the main issue?

Customer: replied 1 year ago.
No. The interior lights do not come on when the door is opened. The door lock/ unlock buttons do operate correctly however , and the interior lights respond to the key in and out of the ignition and doors , Etc. Please read the above carefully. I believe the main issue is the door ajar light issue, and the annoying side effect is that I can't program any key fobs.
Expert:  mike switzer replied 1 year ago.

to be honest it does sound like your keyless control module is inoperative and needs to be replaced. the rx8 did have issues with them not working properly.

i would if this was my vehicle replace the keyless control module.

Customer: replied 1 year ago.
Sorry somehow I missed this reply. Can I replace the keyless control module myself or does it need to be taken to the dealership for some sort of synchronization with the car? I thought I read it will be undriveable if I were to replace it without some sort of synchronizing? Thanks
Expert:  mike switzer replied 1 year ago.

it will need to be done at the dealership so the are able to program the keys. they car will not start if replaced by you.

if you have no further questions i would appreciate a star rating as this is how i am compensated from the site.

Customer: replied 1 year ago.
I do not believe the problem can be the keyless control module. Every other aspect that it operates seems to be fine. I believe the problem clearly lies in the door open sensing circuitry. (specifically the drivers door, though it doesn't sense any of them) When I run the diagnostic above, the 04 test which tests the door circuit, there is no change, and it is the only test out of all those diagnostics to fail. Further, the security light diagnostic below works properly (stays on for 3 seconds after turning the key to the on position without any error codes) which suggests that the keyless control module is in fact working. The car simply never gets a signal a door is open. I've removed the door switch from the driver door to ensure an open in the circuit ( which is the open door state of the switch) to be certain, and still no change.
I need some help with which harness or connection, etc. would be involved in the door open/closed status for all the doors/hood/trunk. This would be the key to this problem. Bot***** *****ne I'm sure if I can get a door ajar light that I could program the key fobs and everything else would work that relies on the door switch status. Along those lines, as I stated, running that diagnostic 04 test above fails. What does that mean? Does it mean its a problem directly with the insturment cluster or just somewhere with the door circuit? That could be very helpful information. Thanks
Customer: replied 1 year ago.
Heres the security light diagnostic I mentioned in the last mail.Immobilizer System (DTC Inspection)1. Turn the ignition switch to the ‘ON’ position
2. Verify the security light state.
* If there are any malfunctions:
o After any malfunction is detected, the security light will function as follows for approximately 1 min.
DTC 16 and lower: Flashes
DTC21 and higher: Illuminates
* If there are no malfunctions:
o The security light illuminates for approximately 3 seconds and goes out.
3. When any malfunction has been detected, read DTCs via flashing patterns displayed after the security light flashes or illuminates for approximately 1 minute.
* A verified DTC is flashed 10 times repeatedly by the security light.
* If multiple DTCs are verified, the security light displays only the smallest DTC.DTC Table (Immobilizer System)
Security light flash pattern:
∩__∩_________ = No detected communication with the coil
∩__∩∩________ = Coil malfunction
∩__∩∩∩_______ = The key ID number data cannot be read or key ID registration error
∩__∩∩∩∩______ = The keyless control module cannot read key ID number data normally
∩__∩∩∩∩∩_____ = The keyless control module has detected unregistered key ID number
∩__∩∩∩∩∩∩____ = Communication error between the keyless control module and the PCM (no response or mismatched conditions)
∩∩__∩_________= Only one key ID number is *****
∩∩__∩∩_______ = Communication error between the keyless control module and the PCM (data transfer error)
∩∩__∩∩∩______ = ID number data in the PCM and the keyless control module do not match.
NOT ILLUMINATED = Keyless control module malfunction
Customer: replied 1 year ago.
OK, I found this associated with that 04 instrument cluster code that is not working out of the RX-8 manual:Check code 04 Door switch ON/OFF signal
STEP INSPECTION CONDITION DISPLAY ACTION
1 Open the front driver side door. (The door
switch is on.)
Close the front driver side door, then go to the next step.
Verify that the voltage of the instrument cluster terminal 2E is 1.0 V
or less.
If the voltage is as specified, replace the instrument
cluster.
If the voltage is not as specified, inspect the
following parts:
Door switch
Wiring harness (Instrument cluster—
door switch)
2 Close all doors.(Door switches are off.) Verify that the voltage of the instrument cluster terminal 2E is B+.
If the voltage is as specified, replace the instrument
cluster.
If the voltage is not as specified, inspect the
following parts:
Door switch
Wiring harness (Instrument cluster—
door switch)
Input signal to the instrument cluster is normal.I think this will give me the answer to my problem. Can you help me on how to test the voltage to this terminal 2E? Key in/out? battery connected/disconnected? Where to connect to ground? I have directions on how to remove the instrument cluster, it's relatively easy in this car.
Customer: replied 1 year ago.
Alos what would voltage B+ be? Thanks
Customer: replied 1 year ago.
B+ is battery voltage, got it. test with battery connected, key in, got it.I already removed the instrument cluster. However when I test the 2E pin, or any pin on the instrument cluster connector for that matter, I don't get any voltage with my voltmeter (+ to the harness female plugs, - to a verified battery ground) with the key in the on position. So I can't seem to trouble shoot the 2E pin when I can't get voltage from any of the pins. I've verifed my voltmeter is working well and good connections and scale on the voltmeter.Is this circuit electrically isolated from the car ground or something? I can't figure out why I don't get voltage from any of the pins when I know the other functions work fine. How could they work without any voltage signal to them? I'm at a loss. Please help, I have to be close to figuring this problem out, thanks