How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask 350matt Your Own Question
350matt
350matt, Engineer
Category: Mazda
Satisfied Customers: 20930
Experience:  Mechanical Engineer BEng Hons22 years experience
12772297
Type Your Mazda Question Here...
350matt is online now
A new question is answered every 9 seconds

I have a 1985 mazda coupe fuel injected it starts up fine

Customer Question

i have a 1985 mazda coupe fuel injected it starts up fine can drive about 1 k then it shuts down let it cool down for 5 min and you can drive afurther 1k and it shuts down can you help thank you
bert
Submitted: 1 year ago.
Category: Mazda
Expert:  350matt replied 1 year ago.

Hello

This sounds like an electrical actuator or sensor at fault .Usually when you can cycle the ignition key on / off and then restart the engine and the fault is gone temporarily this indicates that this is an electrical component causing this issue.

This could be a wiring issue as things tend to expand when hot and its possible a poor or partial electrical connection is being pushed apart on one of the major sensors so check the connection plug and wiring to the following;

Airflow meter

Crank position sensor

Cam position sensor

O2 sensor

Throttle position sensor

unplug each in turn and use some switch / contact cleaner spray on the pins to ensure its all grease / dirt free

Also worth checking the connections to the fuel pump for the same reason - unplug each in turn and give them a good squirt of switch / contact cleaner - Not WD40

and also unplug and inspect the main power relays and fuses for signs of overheating or corroded terminals - so the ones for the ECU and the fuel pump

And also unplug the wiring loom connections in the engine bay one at time and inspect for corroded or recessed pins.

Check the resistance of the spark plug leads ( 13-15Kohm / metre) and replace if any doubt or high resistance - Also replace the spark plugs if any of them fail this checklist:

http://www.ngksparkplugs.com/tech_support/spark_plugs/faqs/faqread.asp

Also its worth checking that the electric pump that feeds the injectors is working correctly, it should run for a few seconds then switch off when you first turn the ignition on. If the connections to this are corroded or damaged then the pump could stop at any time. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse, ideally measure the voltage at the pump and check its getting 12V