How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Drew Your Own Question
Drew
Drew, Super Mazda Tech.
Category: Mazda
Satisfied Customers: 2188
Experience:  19 yrs. experience. Mazda Senior Certified Tech, with Ford, Linc. & Merc. experience. ASE L1 Advanced Certified Master Tech.
49548721
Type Your Mazda Question Here...
Drew is online now
A new question is answered every 9 seconds

Truck is hard to start, when started it jerks a mile then

Customer Question

Truck is hard to start , when started it jerks for half a mile then smooth's out
Submitted: 11 months ago.
Category: Mazda
Expert:  Greg replied 11 months ago.

Which engine do you have in this car .

Is the check engine light on when the engine is running .

When engine is jerking is there exhaust smoke coming out ,if yes what colour .

Greg

Customer: replied 11 months ago.
The engine light is not on when running. When starting is cranks and tries to start and has occasional backfire, it tries and dies and suddenly starts at high rpm. If I just sit there for couple of minutes the engine will increase and decrease for several minutes. No visable exhaust smoke.
Customer: replied 11 months ago.
When it does smooth out I have run it at 70mph on freeway for 10 miles, smooth a silk
Customer: replied 11 months ago.
Also I have used cleaner to clean injectors to no avail
Customer: replied 11 months ago.
The small engine
Expert:  Greg replied 11 months ago.

Can you check for malfunction codes .

When cranking and no start check and see if you have spark .

Common for this type of issue is spark plugs try new if old and makes sure they are not Bosch plugs .

Greg

Customer: replied 11 months ago.
Plugs were firing, as I stated before when it did start it ran smoothly. While waiting for answer to my previous question over weekend I replaced O2 sensor on converter, the recommendation of friend, it cleared the problem. Therefore I do not need further help in this matter, thank you anyway. I would expect return of unused portion of remittance. Thank you.
Expert:  Greg replied 11 months ago.

If O2 sensors where bad you would have the relevant codes normally .

Test drive a few days and see what happens .

Your deposit is still in your account and you can have this refunded anytime you want but lets wait and see

Rgds Greg

Customer: replied 11 months ago.
Greg: You were right, altho the engine starts quickly now, I find that it still "bucks" for mile or so until engine is warm and then everything is fine. Stop for ten minutes and it will buck again as before. I do not have any diagnostic codes or devices. I get the impression through sound and feel that it is getting too much gas or perhaps not enough. Thank you.
Expert:  Greg replied 11 months ago.

Can you pull the plugs and take a photo of them for me ,i would like to see the condition the plugs are in ?

Greg

Customer: replied 11 months ago.
The plugs were changed a year ago along with wires. I haven't had time to pull them. Hope to this coming weekend.
Expert:  Greg replied 11 months ago.

Okay no problem .

Do you have the possibility to carry out a fuel pressure test .

Greg

Customer: replied 10 months ago.
I pulled plugs, they seemed to be fine, no buildup nor residue. Do no have a way of testing fuel pressure. I can start it in a couple of cranks by not touching the throttle at all until it starts, maybe three or four cranks, then it comes to life on high idle. and still bucks for a mile then smooths out. Seems to me that its getting too much fuel if I use throttle while attempting to start. Very confusing, also the bucking stops when I take my foot off throttle when bucking.
Expert:  Greg replied 10 months ago.

When the engine starts and starts running poorly check the smoke and smell of the fums coming out the exhaust .

does it smell rich of fuel .is there any colour in the exhaust smoke .

PS what make of plugs do you have fitted

Greg

Customer: replied 10 months ago.
Greg I could not get back on line sooner. I think based on my own observation that the problem may be in the throttle. I am not sure if it is hydraulic, mechanical or electrical or combo of those, however I have started it many times in the last week or so, I turn the ignition on without ever touching the foot feed at all, it usually starts on first crank when it starts, if it does not, I may have to crank many times before it fires off and then it just barely runs and back fires and bucks for quarter mile, IF when in the middle of this procedure I give it just a little gas, it chokes it and engine dies, as long as I just sit there and let the engine spit and cough if will all of a sudden smooth out at high RPM's and everything is fine. We have changed both fuel-air sensors, so what other possibilities are left except fuel adjustment. stumped and ready to throw in towel. Truck has only 80K miles on it.
Expert:  Greg replied 10 months ago.

Are Bosch plugs fitted .

Greg

Customer: replied 10 months ago.
The plugs are not Bosch. I am not sure that it could be plugs, if when started the truck runs smoothly at all speeds after the initial bucking for quarter mile. We have run diagnostic on truck and have changed the top and bottom air sensors. The problem is that we have spent a significant amount of money on parts already as suggested by the diagnostics without any resolution to problem. Altho the truck is 16 years old it has only 80K miles on it. Even if running good the worth of the truck is not there to spend much more money without the hint of success. I have a smog test looming in May and even if I wanted to sell I cannot with the engine the way it is now. I can start to with much grinding and soon the battery will need replacing, therefore my only option would be to junk the truck. If you have some idea to try please let me know , if not let me know. Thank you J Wendt.
Expert:  Greg replied 10 months ago.

Even thought you said the check engine light is no on and possible that you do have malfunction codes .

Take a drive down to your local autoparts shop like autozone and get a free code check .

You may find codes this will help .

Greg

Customer: replied 10 months ago.
My son in law has the codes, they pointed to the 02 sensor which we have changed to no avail. Because the only options left are to take it to Mazda shop and let them run wild with costs, trying to figure it out, or Donate it to good cause, which is what I have decided to do. I have spend much too much time and money on it. I will simply run it the way it is until I have to get it smogged (in May) it will not pass the way it is and get some other wheels. I therefore consider this episode a failure. I do not blame you as other mechanics have failed and you are simply going on what I tell you. However I do not feel I should pay as no concrete recommendations have been forth coming. Thank you for your time J Wendt
Expert:  Greg replied 10 months ago.

Okay understand J .

If you want i can put you onto another expert that may of had this same problem and know what to do .

Thank you for using justanswer .

Rgds Greg

Customer: replied 10 months ago.
No Greg, I am just fed up with it. Computer, sensors and all the new stuff is nice but expensive to maintain. I have torn down engines before in the days when a socket set and crescent wrench and common screw driver was about all you needed. Thanks again
Expert:  Greg replied 10 months ago.

Okay i will opt out and .

Go toy customers service and ask for a refund ,

Rgds Greg