How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Eric Your Own Question
Eric
Eric, Automotive Repair Shop Manager
Category: Mazda
Satisfied Customers: 30591
Experience:  20+ yrs. experience as repair shop manager and technician.
3195632
Type Your Mazda Question Here...
Eric is online now
A new question is answered every 9 seconds

I've got a 2005 mazda 6 s 3.0 grand touring wagon. I bought

Customer Question

Hello! So I've got a 2005 mazda 6 s 3.0 grand touring wagon. I bought it with a running engine that sounded rough. (I wanted this to be my project car) So I bought it...and unfortunately replaced the engine as well as ECU. I did the ECU first through Mazda dealer and then the remanufactured engine with 2 year warranty through friends shop. Now the car wont turn over. Not sure where to go from here. Trying to avoid dealer but if this is my only option to get the issue fixed then so be it.
Submitted: 1 year ago.
Category: Mazda
Expert:  Eric replied 1 year ago.

HI,

I am sorry that you have not been helped yet. I just came online and saw your question

Ok, did the no start, no crank condition happen immediately upon installing the reman engine?

What has been tested and/or replaced at this point for the no start, no crank condition?

I need to know if it is automatic or manual transmission, as well as whether it has a remote start on it, and the vin number to pull the schematics.

Customer: replied 1 year ago.
It is an automatic trans with no auto start option. Just the factory anti theft system. It had quite a bit of work done to it at my grandpa's buddies shop. It's got a new fuel pump and steering fluid.
Customer: replied 1 year ago.
Let me look more into this by calling my grandpas mechanic.
Customer: replied 1 year ago.
The vin is: 1YVHP82D855M08831
Customer: replied 1 year ago.
This car did run when purchased. So I know whatever happened did happen during the major work. must have messed with the wiring harness maybe? The code that comes up is U0155.... User 101, User 121, User 155.... Or something like that! Just got that off the phone from the dealer in Van Nuys that installed the new ECU.
Customer: replied 1 year ago.
Oh! And to answer your question a ky the motor cranking.. No, after we installed the engine it won't even get a crank in.
Expert:  Eric replied 1 year ago.

HI,

Ok, those a communication code faults. There are several control modules in your vehicle and they have to communicate with each other via data bus lines, much like several office computers connected to each other.

Ok, this make take a few hours of going thru the wiring diagrams as there around 30 involved with the control modules and see what I can come up with

Expert:  Eric replied 1 year ago.

hi,

Sorry, meant to type Hyundai. Those are for yours.

That would be correct, just the rubber insulators/hangers are all that hold the system to the undercarriage.

front pipe with converter part number is(###) ###-####/p>

rear pipe with muffler part number is(###) ###-####/p>

I dont have part numbers for the insulators or gaskets.