How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190
peterpete190, Auto Technician
Category: Mazda
Satisfied Customers: 26371
Experience:  Auto repair Technician with 17 years experience.Past ASE and other certifications.
14928985
Type Your Mazda Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

Mazda B2600: 1990 Mazda B2600 2wd with 295,000 miles on it.

Customer Question

1990 Mazda B2600 2wd with 295,000 miles on it. When it is cool outside it starts and runs fine. When it is hot outside it crankis but will not start unless I pump the accelerator. It will run rough at first and then smooth out but it will not rev over 3000 rpm. When I put it in drive or reverse it will die unless I coax the gas pedal.
My mechanic says fuel pressure is good. He said the output voltage from the ECU was low so he replaced the ECU. It did not help. He gave up. Any ideas or is it time to take it to the salvage yard?
Submitted: 1 year ago.
Category: Mazda
Expert:  peterpete190 replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
If the engine coolant temp sensor signal was not checked this should be done as this can cause this type of fault here.If it is reading cold all of the time this can lead to engine running to rich on fuel and cause hard starts when warm and power issues.
Thanks Pete
Customer: replied 1 year ago.
Thanks, I will get out my ohm meter and check the water thermosensor. Will let you know the results.
Expert:  peterpete190 replied 1 year ago.
Your welcome.Let me know how this turns out here and if you need anything else.
Thanks Pete
Customer: replied 1 year ago.
I could not find my meter so I just ordered a coolant temp sensor. I ordered one from Autozone but the connector would not fit. . I ordered one from napa and it fit. However, it did not fix the problem. Any other ideas?To repeat the problem: I go out when it is cool in the morning and it starts up and revs up fine. If I take a drive it will do fine for a while and then it looses high end power. If I go out in the afternoon to check it, It cranks but will not start until I tickle the throttle a bit. Once started it will run rough at first and then smooth out some. But, it will not rev over 3000 rpm.
Expert:  peterpete190 replied 1 year ago.
From here this does sound like a fuel issue causing this issue.I would get another opinion if you can on the fuel pump and fuel system to see if any issues are found.If a fault is found with the fuel system it will need repaired.This sounds like the fuel pump is acting up intermittently and it may be when it was checked the first time it was operating properly but acts up off and on causing this here.
Thanks Pete