How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Mazda
Satisfied Customers: 34486
Experience:  35 years as a automotive tech
7276279
Type Your Mazda Question Here...
Ron is online now
A new question is answered every 9 seconds

My 2000 mazda mpv is giving me a new set of problems which

Customer Question

my 2000 mazda mpv is giving me a new set of problems which is preventing it from starting now. So far i have changed the fuel pump, replaced the fuel pump relay and i am satisfied that i have a good fuel pressure.I also connected a test spark plug to a
few of the spark plugs and they did not fire. where do i go from here?
Submitted: 1 year ago.
Category: Mazda
Expert:  Ron replied 1 year ago.
Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
If you can tell me what model and the engine size your Mazda is I can direct you in the next step. I am off today but will return tomorrow, post back to this post with this information and I will direct you from there.
Customer: replied 1 year ago.
The Mazda model number is ***** Vin No. JM3LW28G1Y0140733
6 CYLINDERS, 3.OL
Expert:  Ron replied 1 year ago.
Start first with checking to see if you are lacking injector pulse as well as n spark, take a 12 volt test light and place the test end on the power side of the injector connector and the ground end on the other wire and crank the engine over, if you have pulse the light should flash while cranking. Check this and let me know the results. Im here all day today.
Customer: replied 1 year ago.
I have checked the wires to the injectors one wire has no volts and the other has 12 volts and no pulsation while cranking. I have also checked the four wires at the ignition coil pack, one has no volt and the others three have 12.3 volts. none of these wires pulsate while cranking.
Expert:  Ron replied 1 year ago.
SO are saying you have no injector pulse and no spark to the spark plugs?