How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Crawford Your Own Question
Wayne Crawford
Wayne Crawford, Shop Owner
Category: Mazda
Satisfied Customers: 3904
Experience:  General Repair Shop Owner
66997337
Type Your Mazda Question Here...
Wayne Crawford is online now
A new question is answered every 9 seconds

Tribute v6: , I have a 2008 Mazda Tribute v6. Battery went

Customer Question

Hi, I have a 2008 Mazda Tribute v6. Battery went completely dead and needed to be replaced. I need to perform a smog check but a tech checked the car and said that it will fail the smog check due to some monitors not being ready. He mentioned O2, O2 Heater and Catalyst sensors not ready. EVAP and EGR are ready. I have drive car about 300 miles since the battery replacement, but monitors are still not ready.
I have tried various driving cycle patterns that I found, but none of them worked.
So my question is: is there a known driving pattern that will set monitors to ready state?
Submitted: 1 year ago.
Category: Mazda
Expert:  Wayne Crawford replied 1 year ago.
Hello. My name is ***** ***** I will be helping you today.I am attaching the drive cycle for this vehicle.If any drive cycle will work this one will. This is straight from mazda for your specific vehicle. If that doesnt work I would suspect a questionable o2 sensor.
Customer: replied 1 year ago.
I have already tried this drive cycle and monitors are still not ready.
Expert:  Wayne Crawford replied 1 year ago.
What are your oxygen sensor readings?
Customer: replied 1 year ago.
The car was sitting for a few hours. Initial readings were 0 for Bank 1 and 2, and for sensor 1 and 2 of each bank. After engine run for few minutes readings were changing. Bank 1 Sensor 1 - 0.57 Bank 1 Sensor 2 - 0.295, Bank 2 Sensor 1 - 0.375, Sensor 2 - 0.54 But this values were changing every few seconds
Expert:  Wayne Crawford replied 1 year ago.
Hold the RPMS at about 1500 for a minute while monitoring them and tell me what they are switching between.
Customer: replied 1 year ago.
I can see only 2 of the sensors at the same time. I started the car and let it idle for about 1 minute, then I have connected the scan tool. Sensor 1 Bank 1 0.19 - 0.64 - 0.580 Sensor 1 Bank 2 0.05-0.625-0.575 Sensor 2 Bank 1 0.805-0.820-0.425 Sensor 2 Bank 2 0.595-0.6-0.32
Expert:  Wayne Crawford replied 1 year ago.
Have you had any work done on this recently?
Customer: replied 1 year ago.
No, nothing major was done to the vehicle. My A/C also quit working even though it works when coil is activated by bypassing relay. I am beginning to suspect that there is something going on with the PCM.

Related Mazda Questions