How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee
Amedee, Mazda Technician
Category: Mazda
Satisfied Customers: 24759
Experience:  ASE Technician advanced level specialist. Wisconsin certified emissions state inspector
279429
Type Your Mazda Question Here...
Amedee is online now
A new question is answered every 9 seconds

2007 MAZDA 6: CHECK ENGINE LIGHT..po134replaced 02 SENSOR

Customer Question

2007 MAZDA 6 CHECK ENGINE LIGHT ON
CODES PO032 AND PO134
REPLACED 02 SENSOR
Submitted: 4 years ago.
Category: Mazda
Expert:  Amedee replied 4 years ago.
Hello!

Did you still need help?

Which o2 sensor did you replace?

Can you tell me the wires colors going to the o2 sensor?

Have you checked the inputs to the o2 sensor?
Customer: replied 4 years ago.

Hello

I replaced bank 1 before cat.

the 02 has 2 connectors i have power in and out 02 sensor

Expert:  Amedee replied 4 years ago.
Hello!

Your sure it was bank one?

If so, and you have power to the o2 sensor and a good ground, the only other possible causes would be a wiring issue or a bad computer.
Customer: replied 4 years ago.

WHERE DOES IT GET ITS GROUND FROM?

IS POWER GOING IN AND OUT 02 RIGHT?

 

Expert:  Amedee replied 4 years ago.
The computer actually grounds the o2 sensor to activate the heater element. It should have power all of the time when the key is on but the computer controls the heating element. It grounds the circuit to allow currently flow. The computer could be bad or you could have a wiring issue from the o2 sensor back to the computer causing these codes.
Customer: replied 4 years ago.

DO YOU HAVE A WIRING DIAGRAM FOR THE

BANK 1 SENSOR? IT HAS 2 CONNECTORS

AND 5 WIRES 3 PINS IN 1 2 ON THE OTHER ONE

Expert:  Amedee replied 4 years ago.
YES.. I have a wiring diagram for anything on your vehicle but I cannot copy and paste it on this page because it is against copy write laws. I can however, recommend a few places for you to try. Some are free but most are not.
Customer: replied 4 years ago.
OK WHERE?
Expert:  Amedee replied 4 years ago.
Try this place first. They are free.. but they they are limited..

http://www.bbbind.com/tech_database.html


If that does not work, then you will have to go to alldata.com
Customer: replied 4 years ago.

THE 2 PIN CONNECTOR SHOULD I HAVE POWER

GOING IN AND OUT OF FRONT 02 SENSOR?

OR SHOULD THERE BE A GROUND THERE FROM 02 SENSOR

Expert:  Amedee replied 4 years ago.
Which wire has power with the key on?
Customer: replied 4 years ago.

WHITE WIRE GOING TO 02 SENSOR CHANGES TO BLUE

ON 02 SIDE

Expert:  Amedee replied 4 years ago.
The blue black wire needs to have power with the key on and engine running. This might just be your problem.
Customer: replied 4 years ago.

I do not see a blue black wire

I have power to a white wire coming from harness going to a blue wire going to 02 sensor.

same connector has a white with black wire no power.Has power when key on.

power coming from yellow wire 02 side to connector

Expert:  Amedee replied 4 years ago.
Can you upload a picture?

Can I get your VIN?
Customer: replied 4 years ago.

vin 1yvhp80c775m38853

what would you like a picture of?

Expert:  Amedee replied 4 years ago.
Ok.. yes.. that is correct. I pulled a diagram from a V6 engine.

It sounds like the o2 sensor has power on the white wire.

Clear the codes and drive it around again and see which code pops back into the computer.

If you don't have a wiring issue, then you could have a bad new o2 sensor or a running condition with the engine.
Customer: replied 4 years ago.

I drove around the block the light comes on

codes po032 po134 i can make it happen on the lift

this is the second new 02 sensor different brand also

 

Expert:  Amedee replied 4 years ago.
Ok.. then the only thing left would be a wiring issue or a bad PCM.

I hope this helps! Please don't forget hit the green accept button so that I may get credit for the time that I have spent with you. This is necessary for me to be paid for my work and get credit for assisting you. Your question will not close, and you will still have the opportunity to follow-up if needed. Leaving a bonus and positive feedback is not required, but doing so is certainly appreciated!

I do hope you are as honest with me about your vehicle as I have been with you. If you have any further questions or if you need more assistance, just hit the reply button and we can continue our conversation. Please remember, even if you accept my answer now, you can still reply or respond back to this thread at any time you wish at no further cost to you.

In addition, please allow time between answers as I may be off line spending time with my family or assisting other customers. You can always request me by using the link through my profile page. Just Click on "AMEDEE" next to my picture and I will be sure to respond back in a timely manner.

Thanks in advance!

Best Regards

AMEDEE
Customer: replied 4 years ago.

i was thinking wiring to

i am looking for a wiring diagram for the 02 sensor powers and grounds

resistance testing.

2007 mazda 6 4cyl obd codes po032 and po134 after 3 key cycles codes will show.

Expert:  Michelle-Mod replied 4 years ago.

Hi, I’m a moderator for this topic. Your Professional has opted out and I wonder whether you’re still waiting for an answer. If you are, please let me know and I will do my best to find another Professional to assist you right away. If not, feel free to let me know and I will cancel this question for you. Thank you!

Related Mazda Questions