How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jason Your Own Question
Jason, Marine Mechanic
Category: Marine Electronics
Satisfied Customers: 500
Experience:  Degree in Marine Technology, Also Certified with Mercury Marine, MCM, MIE, VP, Yamaha, Honda, Suzuki
Type Your Marine Electronics Question Here...
Jason is online now
A new question is answered every 9 seconds

I have a raymarine pathfinder rl70c radar and a rc520

Customer Question

I have a raymarine pathfinder rl70c radar and a rc520 chartplotter, the charts no longer appear on the radar display?
JA: Sometimes boat issues seem like they'll be really complicated, but end up being easy to fix. The Marine Electronics Specialist I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so the Marine Electronics Specialist can help you best.
Customer: Charts display worked until a month ago, I still have radar etc.
JA: Is there anything else important you think the Marine Electronics Specialist should know?
Customer: no
Submitted: 11 days ago.
Category: Marine Electronics
Customer: replied 11 days ago.
I have checked the HSB cable for continuity and it checks OK
Expert:  Russell H. replied 11 days ago.

Hi, thank you for contacting My name is Russell. I will do my best to provide the right answer to your question.

Expert:  Russell H. replied 11 days ago.

That is almost certainly a setting that needs correcting. Settings on electronic devices ideally should be set a certain way and never have to be corrected again... but what with being turned On and Off and On again, what with various other factors, settings sometimes spontaneously change.

Which device of the two (RL70c, and RC520) are the charts no longer appearing on with the radar display?

And, does the radar display still seem to be functional aside from the lack of chart display?

Customer: replied 11 days ago.
The chart display does not appear on RL70c, all other functions are working normally. I have done a reset on both units, but no fix. I assume the chart display is generated by the RC520 and sent to the radar unit on the HSB cable.
Customer: replied 11 days ago.
I have the units at home, so can't power them up right now.
Expert:  Russell H. replied 11 days ago.

If you never loaded charts onto the RL70c, then they must be supplied from elsewhere.

How is the RC520 connected by 'HSB cable'? between what ports?

Customer: replied 11 days ago.
HSB cable from 520 to rl70, the chip for the charts is loaded into the 520.
Customer: replied 11 days ago.
HSB, high speed bus, has a molded end that fits into a port on each unit.
Expert:  Russell H. replied 11 days ago.


Since that's where the charts are coming through to the radar, then cleaning the ends of the cable would be advisable.

Disconnect each end, scrub with a clean dry brush for 20 seconds. Then wipe down with a clean dry rag cloth until the metal shines, then re-connect firmly.

And see if, when turned On again with cleaned and re-seated HSB cable connection, the charts come back.

This may not work. (Was the reset you did, a settings reset?)

Customer: replied 11 days ago.
Sorry, should have mentioned that I already cleaned the cables. The reset was a system reset, reboots to factory settings.
Expert:  Russell H. replied 11 days ago.

OK: factory settings reset, cable cleaned.

Is there any sign of stress or strain on the cable at any point along its length?

Customer: replied 11 days ago.
no, I used a ohm meter to check the cables, they are OK
Expert:  Russell H. replied 11 days ago.

Is the map file still on the RC520 in usable condition? that would be a good thing to verify, if it isn't recently verified already.

And, what if the factory settings don't include 'getting the charts from the HSB cable' ? I am not sure it does, and will look up that point, unless you know otherwise.

Customer: replied 11 days ago.
The map on the 520 still works. I haven't seen anything in the manual that requires a particular setting to connect the two.
Expert:  Russell H. replied 11 days ago.

Then what's left?

A defective port?

One of the devices is defective?

Customer: replied 11 days ago.
OK, thanks for trying.

Related Marine Electronics Questions