How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jason Your Own Question
Jason, Marine Mechanic
Category: Marine Electronics
Satisfied Customers: 500
Experience:  Degree in Marine Technology, Also Certified with Mercury Marine, MCM, MIE, VP, Yamaha, Honda, Suzuki
Type Your Marine Electronics Question Here...
Jason is online now
A new question is answered every 9 seconds

I have a rd30 as my backup. All I get is dashes when I power

Customer Question

I have a rd30 as my backup. All I get is dashes when I power it up. I have made sure the 0/s power is on but still nothing. Wha should I check next.
Submitted: 5 months ago.
Category: Marine Electronics
Expert:  Charles replied 5 months ago.
Hello, my name is***** will assist you.How is this unit networked together with the main unit?What sensors are connected to this unit?
Customer: replied 5 months ago.
We have harming as our main unit. I don't think it is tied in to the rd 30. The sensor if airmar smart senser
Customer: replied 5 months ago.
Garmin not harming
Expert:  Charles replied 5 months ago.
Do you know the number on the sensor?
Customer: replied 5 months ago.
Expert:  Charles replied 5 months ago.
Got it thanks.does the temp or speed work on the gauge at all, or is it completely blank?
Customer: replied 5 months ago.
Nothing but dashes
Expert:  Charles replied 5 months ago.
Ok, first item to check is to make sure that the transducer is still attached to he unit. If so, check as much of the transducer wire as you can to make sure that there are not any nicks or cuts in it.

Related Marine Electronics Questions