How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Russell H. Your Own Question
Russell H.
Russell H., Service Tech
Category: Marine Electronics
Satisfied Customers: 10464
Experience:  8+ years of professional experience
13568747
Type Your Marine Electronics Question Here...
Russell H. is online now
A new question is answered every 9 seconds

Left side of side image sgreen is blank on all possible

Customer Question

Left side of side image sgreen is blank on all possible screen options. I have tried raising motor which was never a problem before. Also tried resetinh factory defaults. All other screens and functions work perfectly. Is this a soft ware or a transducer gone bad?
Submitted: 1 year ago.
Category: Marine Electronics
Expert:  Russell H. replied 1 year ago.

Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question.

One side of the screen being blank is not normal in any way; something in the system is probably 'broken' (-it might be the mounting, see below). But what to do and what to check on, depends upon the maker and model # ***** the device with said screen - please let me know.

If the sonar transponder has come a little loose in its mountings, that might cause the problem... and if the sonar transponder has suffered from a recent collision or grounding of the vessel, that might also have caused this problem.

Is your sonar transponder a through-hull type, or an in-hull type? Have you checked whether it is loose in its mounting or that the mounting might be defective otherwise ?

Related Marine Electronics Questions