How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Russell H. Your Own Question
Russell H.
Russell H., Service Tech
Category: Marine Electronics
Satisfied Customers: 9545
Experience:  8+ years of professional experience
13568747
Type Your Marine Electronics Question Here...
Russell H. is online now
A new question is answered every 9 seconds

I have a Simrad nse12 with br24 radar and side scan

Customer Question

I have a Simrad nse12 with br24 radar and side scan transducer and the other day my screen just went dark/blank, not a brightness issue, it just will not power up, however the screen glows grey at night when turned on. Radar doesn't turn on either, I tested the power cord on the back if the unit and was getting 13 volts so now I'm just confused? I tried doing a hard reset, holding the in and out buttons while powering on, waited for 2 beeps and still nothing? Any chance you've seen this before or is it going to be more involved like sending the unit for repair? Thanks
Submitted: 1 year ago.
Category: Marine Electronics
Expert:  Russell H. replied 1 year ago.
Hi, thank you for contacting JustAnswer.com. My name is Russell. I will do my best to provide the right answer to your question.
I think that, from the sound of it, the unit may need to be sent in for repair.
If two different devices are definitely not working, however, that could be different. First, it could be coincidental, but secondly, you must in such a case check the power supplied to both devices very carefully, to make sure it is up to specifications, does not exceed specifications, and does not have 'noise' or AC voltage riding on it.
Customer: replied 1 year ago.
Russell, it is still a mystery to me, it has been working absolutely fine and it just stopped randomly, power is definitely going to the unit as it beeps when powered on, light comes on but nothing appears on screen, and normally when the radar button is pressed it activates the radar dome turning, which it is not doing now. Power is also going to the Simnet router as it is blinking green. It seems like it is frozen and needs to be rebooted but when i do a hard reset it still just remains dark/blank. As for your suggestion of needing additional repair, I am not sure why I should have to pay $31 additional dollars to be told to take it to a repair facility, without any other suggestion. sorry thats just how I feel. I am going to have a marine electronics tech look at it this week and maybe he can help. thank you anyways,
Expert:  Russell H. replied 1 year ago.

Thank you for reading my suggestion... I hope the marine tech can figure out something other than that it be taken to a repair shop. And will, as I recommended, check the supplied voltage to it.

Related Marine Electronics Questions