How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Electronic Engineer
Category: Marine Electronics
Satisfied Customers: 16496
Experience:  Over 16 years of experience installing and repairing electronics.
30970729
Type Your Marine Electronics Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a lowrance elite 7 combo. it is just over a year old.

Customer Question

I have a lowrance elite 7 combo. it is just over a year old. I use an external clamp to attach the transducer to the boat that I remove after every trip. in the last month or so the depth function has worked sporadically. the GPS, temperature, speed functions still work, but the depth either reads 0.0 or some number less than 7 feet that I know to be incorrect. Some times it will eventually start working again on its own. When it first started happening if I turned it off an on again it would start working again but not anymore.
could it be the transducer cable, or transducer itself? assuming it can be fixed, in the future how should I be treating the unit and transducer to prevent problems?
Submitted: 1 year ago.
Category: Marine Electronics
Expert:  Pete replied 1 year ago.
Hi there,
It sounds like the transducer is beginning to fail.
Check all cables and connections are intact and in good condition first, then try fitting a replacement transducer - if the problem goes away, then this confirms that the transducer has a fault.
In future, the transducer can be left permanently mounted on the boat according to the installation guidelines.

Related Marine Electronics Questions