How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jason Your Own Question
Jason
Jason, Marine Mechanic
Category: Marine Electronics
Satisfied Customers: 506
Experience:  Degree in Marine Technology, Also Certified with Mercury Marine, MCM, MIE, VP, Yamaha, Honda, Suzuki
44667847
Type Your Marine Electronics Question Here...
Jason is online now
A new question is answered every 9 seconds

Just installed my Elite 5 HDI. Worked fine after mounting transducer,

Customer Question

Just installed my Elite 5 HDI. Worked fine after mounting transducer, connecting wiring and while completing mounting. Inserted 2015 Fishing Hot Spots Pro USA and worked fine. Went inside for about 2 hours and returned to show my wife after she returned home. The screen opened as normal with Elite Lowrance on the screen but after about 15 seconds the screen value lowered and continued to show Elite Lowrance with change. Read that to restart: press +/_ button and then Start button and hold until an american flag appears then release. I did this but no change....
Submitted: 1 year ago.
Category: Marine Electronics
Expert:  Charles replied 1 year ago.
Hello, my name is***** you for allowing me to assist you today. Your question may take more that one post to get an accurate answer.

With the unit off, remove the map card and see if it will now turn back on.

Related Marine Electronics Questions