How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Charles Your Own Question
Charles
Charles, Marine Tech
Category: Marine Electronics
Satisfied Customers: 3343
Experience:  US Navy (Ret) I have been installing Marine Electronics for over a decade now.
67216606
Type Your Marine Electronics Question Here...
Charles is online now
A new question is answered every 9 seconds

I have a hummunbird 958c with version 4.970 mmc/sd card version...

Customer Question

I have a hummunbird 958c with version 4.970 mmc/sd card version... ill put the trolling motor which has the transducer built in it in the water ... it will show depth and be fine for awhile then all of a sudden it goes haywire showing 250 ft when I can see we are at 30ft,,, sometimes it stays like that for awhile I move around and then suddenly it comes back ,,, other times I try to reset and it wont power off... I have to unplug the unit it comes back on and then its fine again ,, sometimes it stays ok sometimes its the same old crap very frustrating any ideas before I send back to factory or do u know of a good repair center
Submitted: 1 year ago.
Category: Marine Electronics
Customer: replied 1 year ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Video Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Charles replied 1 year ago.
What trolling motor do you have the unit attached to?
Customer: replied 1 year ago.
Minn Kota 101
Customer: replied 1 year ago.
But it acts up when it's not even running
Expert:  Charles replied 1 year ago.
Fortex?
Customer: replied 1 year ago.
What's a fortex Its a 2007 model
Expert:  Charles replied 1 year ago.
the name in the side of the motor.
Customer: replied 1 year ago.
I downloaded new software and installed today gonna try tomorrow see if that fixes it.
Expert:  Charles replied 1 year ago.
That is one possible issue for sure.
Customer: replied 1 year ago.
I'll let ya know tomorrow thanks
Expert:  Charles replied 1 year ago.
Great, If it does have the US2 transducer there is a fuse that could be blown on the trolling motor and that could cause the issue that you are having..Even when it is not running.
Customer: replied 1 year ago.
It's working much better I still get a little interference but I'd like to know more about that fuse you were talking about and also it's a Maxum Pro
Expert:  Charles replied 1 year ago.
Ok,
remove the head cover of the trolling motor. It is held on be 3-4 screws. then you will see a small black fuse holder on a small brown wire. Check that fuse to make sure that it is still good and not blown.
Customer: replied 1 year ago.
I took off three screws and the only thing that was there was like a round Disc I couldn't see any brown wire I could not pull out far Are u sure its a maxumm pro model
Expert:  Charles replied 1 year ago.
If you have the US2 transducer on the trolling motor, there is a brown wire in the head. The fuse was added in 2008.
How old is the depth finder?
Customer: replied 1 year ago.
It came with the boat the boat 2007 is there a serial number on the trolling motor which would help you out
Expert:  Charles replied 1 year ago.
I have the correct diagram for the motor. I was thinking of a 2008.
Is this a new issue with the unit or have you had it for some time?
Do you have a ferrite core installed on the power cable of the 959?
Customer: replied 1 year ago.
The unit came with the boat at the boat for little over 5 to 6 years it's always done that were just bounces up and down with the dad so that's always been an issue but since I've installed the new software it doesn't seem to be as bad. I do not know what a ferrite core or is it whatever came with the boat. I don't think you can take that trolling motor head apart can you access everything from the other side where the prop is.
Expert:  Charles replied 1 year ago.
The core would be in the power line going to the 958. It would be a large round disc about 3" from the plug-in.
Customer: replied 1 year ago.
Yep it's there
Expert:  Charles replied 1 year ago.
Ok great,Humminbird would tell you to install a second core ring. You can get one by contacting Humminbird directly. You will need to remove the power line from the boat at the connections for it. Wrap the line around the core 6 times and then reinstall the power line in the boat. That should take care of the issue. It looks like the top one is this pic.
http://www.tjskl.org.cn/images/czbda7c9-pz1bd65a0-ferrite_core_toroidal_cores.html
Customer: replied 1 year ago.
I was looking at my other hookup the unit in the front of the boat does not have a core ring
Expert:  Charles replied 1 year ago.
It should look like this one here,
http://www.humminbird.com/Products/PC-11/
Customer: replied 1 year ago.
It does not have a ring I'll get one and try it.
Expert:  Charles replied 1 year ago.
The one that I sent from Humminbird is built in to the cord. Most any marine dealer would carry one.

Related Marine Electronics Questions