How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask David Your Own Question

David
David, Mac Support Specialist
Category: Mac
Satisfied Customers: 1371
Experience:  BSc H.Dip Apple Certified Professional
39216975
Type Your Mac Question Here...
David is online now
A new question is answered every 9 seconds

Why does my photoshop elements 6 not work with my mac

Customer Question

Why does my photoshop elements 6 not work with my mac 10.10.5
Submitted: 1 year ago.
Category: Mac
Expert:  David replied 1 year ago.

Hi, my name is ***** ***** I will help you with your Question.

Do you see an error message when you are trying to launch the software?

If not what is happening to stop you using the software?

Thanks in advance, David.

Expert:  David replied 1 year ago.

I just noticed the version of Elements you are using. Here are the system requirements:

  • PowerPC G4 or G5 or multicore Intel processor
  • Mac OS X v10.4.8 through 10.5.2
  • 512 MB of RAM (1 GB recommended)
  • 64 MB of video RAM
  • 1 GB of available hard-disk space (additional free space required during installation)
  • 1024 x 768 display resolution
  • DVD-ROM drive
  • QuickTime 7 software required for multimedia features
  • Internet connection required for Internet-based services
Expert:  David replied 1 year ago.

Your version, Elements 6, will only work on Mac OS X version 10.4.8 to version 10.5.2

Your version of Mac OS X is too new to run Elements 6, You will need to update to the newest version of Elements, and your Mac will need to meet the minimum requirements of the newest version of Elements.

  • 64-bit multicore Intel® processor
  • Mac OS X v10.8 through v10.10
  • 2 GB of RAM
  • 4 GB of available hard-disk space (additional free space required during installation)
  • 1024 x 768 display resolution
  • DVD-ROM drive
  • QuickTime 7 software required for multimedia features
  • Internet connection required for product activation
Expert:  David replied 1 year ago.

If your Mac does meet or exceed the minimum requirements for Elements 13, you can get it here:
http://www.amazon.com/Adobe-Photoshop-Elements-Mac-Download/dp/B00NNZNTAC

Customer: replied 1 year ago.
it has a lot of numbers and says it will send it to mac I hit relaunch and it will not.. I have been in touch with Apple and they say it is an Adobe yhinh but there is no way you can contact adobe
Expert:  David replied 1 year ago.

Yes, your version of Elements will not work in your version of Mac OS X.

You can upgrade to version 13 using the link above to purchase.

You can try the free web version here:
http://www.photoshop.com/tools

Expert:  David replied 1 year ago.

If there are any questions please feel free to ask, I will be glad to help.

Expert:  David replied 1 year ago.

Hi, is everything OK? DO you have any further questions?
Thanks, David.