How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Your Own Question
Mike
Mike, Mac Medic
Category: Mac
Satisfied Customers: 8976
Experience:  Over 20 years IT experience with Apple computers in publishing, marketing and design.
25267123
Type Your Mac Question Here...
Mike is online now
A new question is answered every 9 seconds

I have and a copy of Adobe Photoshop Elements 4 that i used

Customer Question

I have and a copy of Adobe Photoshop Elements 4 that i used several years ago on a different mac.
I now want to install it on my new iMac but when i try I get ab error message "installation failed". I used the original CD to try and install.
I am running Mac OS 10.10.5 on my new iMac.
RichardCustomer
***@******.***
Submitted: 1 year ago.
Category: Mac
Expert:  Mike replied 1 year ago.

I found out Elements 4 is for PowerPC Macs only so it will not run on your Intel Mac with Yosemite you will have to upgrade to version 13, sorry.

If you are satisfied, please kindly provide an OK or Above Rating - so I get paid. Keep in mind you can always come back to this page at any time regarding this question. If we solved your problem, giving me high marks on the survey and / or bonuses are also GREATLY appreciated. Thanks!!

Related Mac Questions