How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Ashik Your Own Question

Ashik
Ashik, Mac Technician
Category: Mac
Satisfied Customers: 9926
Experience:  Bachelor of Computer Application (BCA), 9+ Years of Experience in troubleshooting Macs, iPhone, iPad, iPod etc
16433418
Type Your Mac Question Here...
Ashik is online now
A new question is answered every 9 seconds

I have a MacBook Pro (vintage) and I need to update my

Customer Question

I have a MacBook Pro (vintage) and I need to update my Safari 5.5 to a 7.7+. How do I do that?
Submitted: 1 year ago.
Category: Mac
Expert:  Ashik replied 1 year ago.
Hi and Welcome. My Name is ***** ***** I look forward to assisting you today with your question.
What version of Mac OS X are you using ?
Customer: replied 1 year ago.
10.5.8
Expert:  Ashik replied 1 year ago.

You are currently on the latest Safari that your Mac can handle. If you want Safari 6 or later, then you have to upgrade your Mac OS X 10.5.8 to 10.6 or later version of OS X.

To upgrade to 10.6 or later, you have to buy and install 10.6 Snow Leopard first. You can buy 10.6 Snow Leopard discs from here --> http://www.apple.com/shop/product/MC573Z/A/mac-os-x-106-snow-leopard

When you get the discs, just put it on your Mac and follow the onscreen instructions to upgrade.

After upgrading to 10.6.8 Snow Leopard, you can upgrade to Mac OS X 10.10 Yosemite for FREE. You can download and install 10.10 Yosemite from the App Store application in Snow Leopard for FREE.

When you upgrade the OS X the Safari application will also be upgraded.

I'd strongly recommend to upgrade to 10.6 Snow Leopard or later version of OS X not only for Safari but also for some security purposes. 10.5 is no longer safe especially if you are using for internet purposes.

Please note that, this is not my final answer. If you have any questions or would like any additional information, please don't hesitate to ask and I'm happy to continue to help you.