How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Nick H. Your Own Question

Nick H.
Nick H., Mac Specialist
Category: Mac
Satisfied Customers: 8276
Experience:  Macbook, Macbook Pro, Macbook Air, Mac Pro G5.
Type Your Mac Question Here...
Nick H. is online now
A new question is answered every 9 seconds

I have an early 08 13" Macbook that currently has OS X 10.7.5

This answer was rated:

I have an early 08 13" Macbook that currently has OS X 10.7.5 installed. Is there a newer OS that can be installed on this Macbook or is this the only current available OS?
Hello, and thanks for your question. My name is XXXXX XXXXX I will help you today.

Yes you can download and install Mac OS X Mavericks from Appstore.

On your Macbook, open Appstore and search for Mavericks. Click on Download option. After the OS is downloaded, it will prompt you to install. Usually this will take about an hour or more depends on the internet speed.

Please let me know if you have any questions or concerns. Otherwise kindly rate my answer so I can get credit. Thank you!

Customer: replied 2 years ago.

Thought I read that my system is too old for Mavericks.


Take a look at this info. Your Macbook should work.

General Requirements
  • OS X v10.6.8 or later
  • 2GB of memory
  • 8GB of available space
  • Some features require an Apple ID; terms apply.
  • Some features require a compatible Internet service provider; fees may apply.
Supported Models
  • iMac (Mid 2007 or newer)
  • MacBook (Late 2008 Aluminum, or Early 2009 or newer)
  • MacBook Pro (Mid/Late 2007 or newer)
  • Xserve (Early 2009)
  • MacBook Air (Late 2008 or newer)
  • Mac mini (Early 2009 or newer)
  • Mac Pro (Early 2008 or newer)
Customer: replied 2 years ago.

I don't see mine on the list - early 08 WHITE 13" Macbook (sorry, I didn't previously give you white).

Thanks Randy.

If your Macbook is not a Macbook Pro but rather a normal Macbook, it is NOT SUPPORTED.

MacBook (Late 2008 Aluminum, or Early 2009 or newer)

You can try to double check on this please. Click on the Apple logo top left corner. Select About this Mac and click More info. Check the model again. Is it Macbook or Macbook Pro?

Customer: replied 2 years ago.


Macbook. So Lion is the the only version, correct?

Thanks Randy.

That is correct. Lion is the latest OS X for your Macbook.

Nick H. and 4 other Mac Specialists are ready to help you