How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Computer Engineer
Category: Mac
Satisfied Customers: 17021
Experience:  Over 16 years of computer experience, CISCO certified
30970729
Type Your Mac Question Here...
Pete is online now
A new question is answered every 9 seconds

i downloaded a joomla template. It requires that I install

Customer Question

i downloaded a joomla template. It requires that I install Joomla, which requires me to have have a localhost. I used Mamp and did this. I next loaded the install files to the htdocs folder in mamp which seemed to work and unzipped. I began the install process, but when i begin the database config it gives me the following error: Could not connect to the database. Connector returned number: Unable to connect to the Database: Could not connect to MySQL. can you resolve?
Submitted: 3 years ago.
Category: Mac
Expert:  Pete replied 3 years ago.

Hello,
I am Pete, and I'll be happy to assist with your question today.

 

This error message is usually caused by inputting the incorrect database details. Check that the host name, username and password are all correct, then try again.

 

1.Open your XAMPP control panel
2.Under MySQL click the admin tab, look for PHPAdmin
3.On the right corner under MySQL check your user name and password
4.Use that user name and password for the installation (user name should be without @localhost)
5.If you dont see a password then leave the password blank

 

Customer: replied 3 years ago.

http://localhost/xampp/



This is the message I receive. what now?



MySQL said:


#2002 - No such file or directory
The server is not responding (or the local server's socket is not correctly configured).

Expert:  Pete replied 3 years ago.
Is this the same message as previously, or a different message?
What are you entering as the host name and username?
Are you entering a password?