How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Freddy M. Your Own Question

Freddy M.
Freddy M., Computer Technician
Category: Mac
Satisfied Customers: 18398
Experience:  Years of experience in the IT field
Type Your Mac Question Here...
Freddy M. is online now
A new question is answered every 9 seconds

My Mac Mini is version 10.5.8. We are trying to sync an Ipod

This answer was rated:

My Mac Mini is version 10.5.8. We are trying to sync an Ipod nano and it told us we need I tunes 10.7 or later.
Downloaded Itunes 11.0 and it said it requires Mac OSX version 10.6.8 or later.
What are our options?
Hello my name isXXXXX look forward to assisting and am very sorry to hear that you are having this problem.
Unfortunately the only way to get this to work is to update your system.

You need at the very least OS X 10.6 which will cost about $20 to upgrade.
That will work with iTunes though for the nano it depends on what generation it is.

Customer: replied 3 years ago.

Can I update my system online through the apple website?


Unfortunately no you would need to use a disc.
You can buy the update from here: Click here

The discs are normally shipped quickly.
It should be sent out within 24 hours.

If you have any questions at all click on reply to expert and let me know.

If not please don’t forget to leave a positive rating for my help - it is greatly appreciated.

Freddy M. and other Mac Specialists are ready to help you