How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Mike Your Own Question

Mike, Mac Medic
Category: Mac
Satisfied Customers: 8624
Experience:  Over 20 years IT experience with Apple computers in publishing, marketing and design.
Type Your Mac Question Here...
Mike is online now
A new question is answered every 9 seconds

I just installed T Tax 2012 on my mac book and tried opening

Customer Question

I just installed T Tax 2012 on my mac book and tried opening it ... memo came up "you can't use this version of the application with this version of Mac OS X ... have used T Tax in years past since '08 ... what should i do?

Dave Rhine
[email protected]
Submitted: 3 years ago.
Category: Mac
Expert:  Mike replied 3 years ago.
Please go to the Apple logo on the upper left of the screen, go to About This Mac (DO NOT Select More Info), and tell me the Version (under Mac OS X), the Processor and the Memory, it is all right there.
Customer: replied 3 years ago.


Expert:  Mike replied 3 years ago.
I need the rest of the info please.
Customer: replied 3 years ago.

Processor 2.1 GHz Intel Core Duo


Memory 1 GB 667 MHz DDR2 SDRAM


Startup Disk Macintosh HD

Expert:  Mike replied 3 years ago.
Im afraid you can't run that version of Turbotax on that model Mac, see system requirements here:

Minimum System Requirements

Processor Intel-based Processor (64-bit required for Mac OS 10.6.8)
Operating system

Mac OS X v10.6.8 or later
Mac OS X v10.7.5 or later
Mac OS X v10.8.0 or later

Even though you may be able to install Snow Leopard 10.6.8 the processor must be 64 bit which the Core Duo is not, see below. Sorry.