How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Daniel Your Own Question

Daniel
Daniel, Mac Genius
Category: Mac
Satisfied Customers: 4770
Experience:  Apple certified on desktop and portable, help desk qualified. Have owned and used Macs since 1989.
19098653
Type Your Mac Question Here...
Daniel is online now
A new question is answered every 9 seconds

I have an ipad, and like to travel with that and the transfer

Resolved Question:

I have an ipad, and like to travel with that and the transfer the pages files to my Mac Air for printing and further editing, Now, all at once the Mac Air is not accepting the files, saying I need a newer version of pages. I can't find out how to download this version.

Also, I bought a disk for iLife, and it won't install because it says I need a more recent version of an operating system. I am currently on OSX 1.5.8
Submitted: 6 years ago.
Category: Mac
Expert:  Daniel replied 6 years ago.
Hello, my name is Dan.
I will do my best to help you, the only stupid question is the unasked one.
It is correct, you need Snow Leopard 10.6.4 and you can get that from Apple for $29.00.
Pages is part of iWork and at present is iWork 09, you can get a package deal of iLife 11, iWork 09 and Snow leopard from Apple.
Mac Box Set - Apple Store (U.S.) That will have all the software you need.
Daniel and other Mac Specialists are ready to help you