How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Joseph Your Own Question

Joseph
Joseph, Mac Software Engineer
Category: Mac
Satisfied Customers: 1054
Experience:  I have more than 2 years of experience in computer industry including MAC
27113160
Type Your Mac Question Here...
Joseph is online now
A new question is answered every 9 seconds

I updated my iTunes to the most recent version (10.0.1) and

Customer Question

I updated my iTunes to the most recent version (10.0.1) and ever since my credit card isn't working. It says it needs a valid security code. Everything is right and I've tried several cards and it's not accepting any. Advice?
Submitted: 6 years ago.
Category: Mac
Expert:  Joseph replied 6 years ago.
Chat Conversation Started
Joseph :

Hello

Joseph :

We will try to help you.

Joseph :

This issue is there for many customers after the launching of new version of iTunes.

Joseph :

Lets try reinstalling with an old version of iTunes.

Joseph :

The issue is from Apple, so They will be releasing a new version soon

Joseph :

For now lets try installing iTunes 8.2

Joseph :

Download and install the downloaded iTunes and try to purchace.

Joseph :

Let me know how it goes.

Joseph :

Feel free to ask anything. Click ACCEPT button to close this session.