How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask iteachmac Your Own Question
iteachmac
iteachmac, The Duke!
Category: Mac
Satisfied Customers: 865
Experience:  Mac help ,music midi expert, logic pro recording ,electrical installation ,ilife & all mac computing
28671728
Type Your Mac Question Here...
iteachmac is online now
A new question is answered every 9 seconds

I have a mac recent model I cannot find a driver for my

Customer Question

I have a mac recent model I cannot find a driver for my ML-1610 Customer
Submitted: 7 years ago.
Category: Mac
Expert:  iteachmac replied 7 years ago.
Hi , I would like to assist you with the task .

Please find and download this driver or your Mac , it should include support for your printer.

http://www.guigo.us/mac/splix

or

use :-
ML-1710 Mac OS 10.2.4 or higher, Mac OS 10.4-10.5 (ver.0.97)
Use Samsung ML-1710 as the driver, even if you have a ML-1610.

http://org.downloadcenter.samsung.com/
downloadfile/ContentsFile.aspx?CDSite=
au&CttFileID=196410&CDCttType=DR&ModelType=
N&ModelName=ML-1710&VPath=DR/200407/
20040714091350156_SPL2.dmg


More info here :-
http://briantannerresearch.blogspot.com/2007/05/samsung-ml-1610-printer-on-mac-os-x.html

Thanks.
Customer: replied 7 years ago.
hi Duke I tried splix verified for snow leopard no go the second download was fine
thanks robert pearce
Expert:  iteachmac replied 7 years ago.
Ok that's good news :)

It seems Samsung are a little slow on there driver updates or support for older products .

Please let me know if you need any extra help.

Thanks.
Customer: replied 7 years ago.
Thanks ITEACHMAC
I always have had trouble with Samsung the site is not intuitive and even in PC format they make it difficult for the novice to update older products
Your fix using splix 1.1.0is fine thankyou again
Robert Pearce akaCustomer
Expert:  iteachmac replied 7 years ago.
Hi , glad it worked out ,
please can you click accept on the Answer post , as i don't get paid otherwise .

Thanks:)

Related Mac Questions