How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Daniel Your Own Question

Daniel, Mac Genius
Category: Mac
Satisfied Customers: 4770
Experience:  Apple certified on desktop and portable, help desk qualified. Have owned and used Macs since 1989.
Type Your Mac Question Here...
Daniel is online now
A new question is answered every 9 seconds

Hello, I have a Canon MP 560 printer. I am operating a Mac

This answer was rated:

I have a Canon MP 560 printer. I am operating a Mac on OS X 10.6 (Snow Leopard).
I want to operate my printer via my home wi fi network. I thought that I had downloaded the correct current driver from the Canon website. Upon activation, the driver detected the printer. When attempting to print, although it seems to be communicating with the printer (and I can even see the printer cartridge levels), although my screen tells me that the document is "printing", nothing more happens.
Have I got the current driver for OS X 6.10? Can you please help?
Hello Hugh, my name is Dan.
Can you tell me just what steps did you take to install and add the printer?
I ask so that I can spot where the problem may be.
Have you updated to 10.6.2?
What router do you have, LinkSys, Apple, Belkin?
Any detail could be important.
Customer: replied 6 years ago.
Hello Dan,
Thank you for replying to my question.
Yes, I have 10.6.2 installed. The wireless router is a Netgear brand. The printer is online and connected to the network correctly. I know this because a PC in the house is able to print wirelessly using this printer.
I downloaded the Canon IJ Network driver and installed it. I believe that it is the latest one for OS X 10.6. The Mac seems to communicate with the printer because I can see the status of my ink cartridges. In the status box it shows that it is "printing", but nothing happens.
Hoping that you can help.
I am in Melbourne Australia, so there will be a time delay.
Thanks again,
The problem isn't with the printer or the router.
As the printer and PC can attest to.
SL broke many print connections and getting them fixed can be fun.
That said these drivers here may do the job.
SL is claimed to go get the needed drivers to do this on its own, I have seen it do it but not consistently.
The first in the list is for SL.
Then to add the printer try doing this (this is the Apple recommended way to do it).
Let me know.
Customer: replied 6 years ago.
Hi again Dan,
I truly appreciate you getting back to me so quickly. I am at work, so I will try your suggestion as soon as I can later this evening (my time). I will let you know how it goes.
Many thanks,
Ok, let me know. The time difference does throw a wrench into the works.
Customer: replied 6 years ago.
I followed your advice worked!
So grateful.
What do I do now to pay you?
Just click on Accept.
Thank you.
Daniel and 3 other Mac Specialists are ready to help you
Customer: replied 6 years ago.
Hi Daniel,
You may remember that you assisted me a little while ago (very helpfully).
I presume that this message includes the previous message threads.
I am attempting to use the printer's scanner using the Solution Menu and MP Navigator wirelessly, as I have been doing successfully with the printer. Is this not possible wirelessly with this scanner/printer? Or have I not downloaded the correct driver/software for the scanner? I get an error box when I attempt to access the scanner via the Mac screen.
If it can be done, please steer me in the right direction to download the current driver needed. I think that there is a MP Navigator/EasyPhoto/Solution Menu suite, but I don't know which the correct one.
I'm happy to pay you as before.
Many thanks in anticipation,
Hugh, as you can see I have just now gotten around and have seen the question.
I will have to get back to you on this, I have a Dr to see this AM.

Customer: replied 6 years ago.
Thank you Dan,
There is a time zone issue anyway, so whenever you have the time. Hoping things go well at the doctor Dan.
This is what I have found out.

t sounds like you have an issue with the installed Canon scanner driver. You mentioned in the other post that when opening Print & Fax and selecting the MP560 under the Scanners heading, the Open Scanner button resulted in a failure. This would stop every other application from working so if the mentioned Software Update doesn't help, delete the current scanner entry in the Print & Fax > Scanners section, download the Scanner Driver for the MP640 from the Canon web site and install. Then add the Scanner again and test using the Open Scanner function.

Have you tried Image Capture?

Customer: replied 6 years ago.
Hi Dan,
Thank you again for your prompt response. Image Capture does not show any scanner as being connected. In Print & Fax, no scanner appears, only the printer. There was no 'open scanner button' in the print & fax section. I should try to download the scanner driver as you suggested. Should I really use the MP 640 rather than the MP 560 driver?
Sorry, that reference got past me. You could always try it if all else fails.
I suggest looking for a specific scanner driver for that. I use separate machines (scanner, printer) I had one AIO long ago before all this wireless stuff.
My scanners are all USB connected and my printers are through my AirPort Extreme.
One thing I do know for sure is that a scanner driver for one scanner will not coexist with another of the same manufacture.
HP for example, I have a ScanJet 4670 vertical and a ScanJet G4050, same HP maker.
If I want to use the 4670 I have to uninstall the drivers for the G4050 and vis versa.
So I have one on one Mac and the other on another. Pain in the rear.
So if you have more than one scanner that may be an issue.
These look promising.
Daniel and 3 other Mac Specialists are ready to help you
Customer: replied 6 years ago.
Thanks again for the great advice and great service! Installed the scanner driver and (keep your fingers crossed) looks like it's all working now.
Much appreciated again Dan
All the best,
I hope it continues to work.
Those multifunction printers are problematic and seem to quit for no reason.
Thank you.