How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Jeremy Chow Your Own Question

Jeremy Chow
Jeremy Chow, Mac Genius
Category: Mac
Satisfied Customers: 57
Experience:  Use of Mac OS both professionally (design/web oriented) and individually for the past 7 years
Type Your Mac Question Here...
Jeremy Chow is online now
A new question is answered every 9 seconds

I have unlocked and jailbroken my iphone 2G using QuickPwn.

This answer was rated:

I have unlocked and jailbroken my iphone 2G using QuickPwn. I am running the 2.2.1 version of itunes and my modem firmware is 04.05.04. I am trying to use T-mobile on my unlocked phone, but I understand that I have to go back to a firmware of 2.28 or less to run T-mobile. Is this true and if so, how do i "downgrade" my firmware? Any help/advice is appreciated. I am using a Mac laptop for my itunes library. OS is 10.5 leopard.

As far as I am aware, you will need to use Pwnagetool instead of Quickpwn to achieve this. The reason being that you will need extra bootloader files to create a custom ipsw (firmware) image to load to your phone.

The full tutorial is available from iClarified.

Let me know if this is helpful! :-)
Jeremy Chow and 6 other Mac Specialists are ready to help you