How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Aggie Mac Master Your Own Question

Aggie Mac Master
Aggie Mac Master, Mac Genius
Category: Mac
Satisfied Customers: 316
Experience:  B.S. Biology from Texas A&M University and Long-time Mac User
11127226
Type Your Mac Question Here...
Aggie Mac Master is online now
A new question is answered every 9 seconds

i have not been able to load my old version of photoshop 6

Customer Question

i have not been able to load my old version of photoshop 6 on to my new imac. it says that it can't recognize it. i have the serial number and everything but it won't let me install. what can i do.
Submitted: 8 years ago.
Category: Mac
Expert:  Aggie Mac Master replied 8 years ago.
Adobe Photoshop 6 is only compatible with System 8.5, 8.6, or 9.0.

Apple stopped supporting Classic Programs in the new versions of OS X.

The only solution, is to purchase a new copy (CS3 would be optimal).