How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask lexpert Your Own Question
lexpert
lexpert, Lexus Master tech
Category: Lexus
Satisfied Customers: 2100
Experience:  Master Certified with lexus, 8 years experience with Lexus
9414525
Type Your Lexus Question Here...
lexpert is online now
A new question is answered every 9 seconds

It cranks but will not fire, i gave it a shot of fuel and

Customer Question

it cranks but will not fire
JA: Have you checked the fuel supply? And are all the spark plugs working?
Customer: i gave it a shot of fuel and not fire so I figure it is spark. problem has come and gone and now seem here to stay
JA: What is the model/year of your Lexus?
Customer: 2000 RX300
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: yes, gave it fuel to see if fuel or spark and it seems to be spark
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 1 month ago.
Category: Lexus
Expert:  david craig replied 1 month ago.

Hi Im David, thanks for visiting the site. have you tested for spark with a spark tester?

Customer: replied 1 month ago.
no, just figured after i gave it a shot of fuel in the intake if it was fuel it would have fired
Expert:  david craig replied 1 month ago.

when you turn the key to the run position(not start) can you hear the fuel pump run for a few seconds?

Customer: replied 1 month ago.
no pump noise but dont think there ever was
Expert:  david craig replied 1 month ago.

when it was running there was.

Expert:  david craig replied 1 month ago.

do you have anyone to put their ear to the fuel door and listen?

Customer: replied 1 month ago.
never heard one
Expert:  david craig replied 1 month ago.

thats something i need to know to make sure the fuel pump is good.

Customer: replied 1 month ago.
tried but no noise, should it not have fires once I gave it some fuel
Expert:  david craig replied 1 month ago.

should have unless you have multiple issues.

Expert:  david craig replied 1 month ago.

if you cant hear it, the pump is not being energized.

Expert:  david craig replied 1 month ago.

if it didnt fire when you put fuel in the intake, then you are missing spark too.

Customer: replied 1 month ago.
ok now what?
Expert:  david craig replied 1 month ago.

do you have a multi meter?

Expert:  david craig replied 1 month ago.

do you have a spark tester?

Expert:  david craig replied 1 month ago.

ill be back in half an hour. gotta walk the pooch.

Customer: replied 1 month ago.
Expert:  david craig replied 1 month ago.

good. while im gone could you please check for spark?

Customer: replied 1 month ago.
I was told it was the ECU and picked up a used one but unless it is programed with the key it will not work
Customer: replied 1 month ago.
Sorry, need quality time with wife. Need to try again tomorrow.
Expert:  david craig replied 1 month ago.

ok. keep in touch

Customer: replied 1 month ago.
just check and there is no spark
Expert:  david craig replied 1 month ago.

ok. give us a starting point. when you turn the key to the on position(not start), does the check engine light come on?

Customer: replied 1 month ago.
the light is on
Expert:  david craig replied 1 month ago.

good. ok, when you try to start the car does the red security light go out?

Customer: replied 1 month ago.
Expert:  david craig replied 1 month ago.

ok. good. let me pull a print so we can electrically test some things.

Expert:  david craig replied 1 month ago.

ok lets check some fuses. mainly the ones on this print, but anyone that has to do with IGN/ECU/FUEL/START/AM/EFI

Expert:  david craig replied 1 month ago.

HERES A LAYOUT

Customer: replied 1 month ago.
all the fuses are good
Expert:  david craig replied 1 month ago.

ok.

Customer: replied 1 month ago.
What is next?
Expert:  david craig replied 1 month ago.

if the fuses are good. and the engine isnt getting spark or fuel, Double check the 7.5 amp ign. fuse. if that is good. your computer is fried.

Customer: replied 1 month ago.
How do I change the computer since they are programed to the key? I have a different one and when I put it in the security light stays on when I crank it.
Expert:  david craig replied 1 month ago.

the computer and the immobilizer has to be replaced as a set.

Customer: replied 1 month ago.
Where is the Immobilizer?
Expert:  david craig replied 1 month ago.

its part of the ignition switch. its a small black box located inside of the steering column.

Customer: replied 1 month ago.
Can mine be reprogramed or just easier to get the immobilizer off the car I got the computer from.
Expert:  david craig replied 1 month ago.

probably easier and cheaper to get it off the donor

Customer: replied 1 month ago.
Then my keys will still work?
Expert:  david craig replied 1 month ago.

no, you'll need to new key made for the new ignition switch, the immobilizer and igniton switch come out as an assembly.

Expert:  david craig replied 1 month ago.

looks like this

Customer: replied 1 month ago.
I need the ignition switch and immobilizer off the donor car as well as the key if they have it correct?
Can I get my key programed to the immobilizer?
Expert:  david craig replied 1 month ago.

yes, you can have new keys cut/programmed

Expert:  david craig replied 1 month ago.

any update?

Customer: replied 1 month ago.
Changed everything security light does not flash so all should be good and it is still dead.
Now what?
Expert:  david craig replied 1 month ago.

the security light goes out when trying to start?

Customer: replied 1 month ago.
Expert:  david craig replied 1 month ago.

does the light flash when the key is out of the ignition and doors are shut?

Customer: replied 1 month ago.
the light flashes
Expert:  david craig replied 1 month ago.

ok, does the vehicle crank?

Customer: replied 1 month ago.
cranks fine
Expert:  david craig replied 1 month ago.

and still no fuel pump running for a few seconds when the key is on?

Customer: replied 1 month ago.
No fuel pump
Expert:  david craig replied 1 month ago.

ok, gain access to the fuel pump relay. pull it out. with your multimeter find B+ on the relay base. then turn the key on and find switched power in another slot of the relay base. there should be 2 slots that doesnt ever have power also. take a jumper wire and put one end into a slot with 12vdc and the other end into a slot with no volts. ,key on, see if the pump runs

Customer: replied 1 month ago.
Where is the fuel pump relay?
Customer: replied 1 month ago.
the pump runs
Expert:  david craig replied 1 month ago.

ok, now we need to know why it doesnt run with the key on.

Expert:  david craig replied 1 month ago.

i gotta go spend some time with my grand kids. ill be back on tonight

Customer: replied 1 month ago.
Did I get a bad box
Expert:  david craig replied 1 month ago.

i dont think so. do you have a noid light?

Customer: replied 1 month ago.
Noid light?
Expert:  david craig replied 1 month ago.

its a light that plugs into each injectors connector to see if it is getting pulse command from the computer.

Expert:  david craig replied 1 month ago.

harbor freight sells a set really cheap

Customer: replied 1 month ago.
Is that just like checking for spark
Customer: replied 1 month ago.
Going to get one now
Customer: replied 1 month ago.
Got a light and no power anywhere
Expert:  david craig replied 1 month ago.

no power to any of the injectors?

Customer: replied 1 month ago.
I just checked one.
Expert:  david craig replied 1 month ago.

you plugged it in to the connector and cranked the engine and no flashing?

Customer: replied 1 month ago.
that is correct
Expert:  david craig replied 1 month ago.

ok. gimme a sec, thanks

Expert:  david craig replied 1 month ago.

can you check for ground at the one injector that you tested please.

Customer: replied 1 month ago.
The black wire ?
Expert:  david craig replied 1 month ago.

heres a print

Customer: replied 1 month ago.
I will get back to you tomorrow AM
Expert:  david craig replied 1 month ago.

well the injector harness should run together and have a single gorund for all of them. ill talk to you tomorrow.

Customer: replied 1 month ago.
I checked two injectors that have a common blue and red wire and that is a working ground
Expert:  david craig replied 1 month ago.

ok. see what happens to that ground when the key is turned on

Customer: replied 1 month ago.
The ground goes away
Expert:  david craig replied 1 month ago.

ok. the ignition switch is sending power to the side of the injectors when turned on, which is what its supposed to do. next up is to do a continuity check of the fuel injector harness to the computer. check point to point. and also each wire to ground.

Customer: replied 1 month ago.
What am I looking for?
Am I checking the grounds?
Expert:  david craig replied 1 month ago.

no. you are checking the control wires from the pcm to the fuel injectors.

Expert:  david craig replied 1 month ago.

if they all are good on the continuity test, then the computer is bad.

Customer: replied 1 month ago.
Two computers same issue?
Expert:  david craig replied 1 month ago.

if the injector control wiring is good then yes. it cant be anything else. nothing stop the injectors from getting pulse except damaged wiring to the injectors a bad ignition switch or the computer. when you check continuity, make sure you check the grounds in the area of the computer for corrosion or looseness

Customer: replied 1 month ago.
After I ran the fuel pump it fired a couple of time. Will the computer be intermittent?
Expert:  david craig replied 1 month ago.

after you ran the fuel pump, there was enough residual fuel in the lines and rail for it to be able to fire a couple times. did you check the wiring continuity?

Customer: replied 1 month ago.
Why would it fire if we don't have spark?
I will be checking the wires shortly and get back to you?
Expert:  david craig replied 1 month ago.

we need to check for spark again. doesnt make sense

Expert:  david craig replied 1 month ago.

did you check for spark again?

Customer: replied 1 month ago.
This evening,
Expert:  david craig replied 1 month ago.

ok

Expert:  david craig replied 1 month ago.

any update?

Customer: replied 1 month ago.
I am still chasing wires, do you have a diagram of the injector where they go into the ECU?
Also, we still have the issue of no fuel pump running.
Is there a fuse I am missing or a fuse box issue?
I have borrowed a third computer and it still does the same so we can rule that out.
Expert:  david craig replied 1 month ago.

here again

Expert:  david craig replied 1 month ago.

is the red security light still go out when you try to start?

Customer: replied 1 month ago.
Ues
Customer: replied 1 month ago.
Expert:  david craig replied 1 month ago.

ok

Customer: replied 1 month ago.
wires are good. Any ideas where to go next? Still no spark and no fuel pump
Expert:  david craig replied 1 month ago.

let me think about this

Customer: replied 1 month ago.
any ideas?
Expert:  david craig replied 1 month ago.

it has to be a fuse or a connector that not connected. recheck every fuse in the vehicle. even it you dont think it has anything to do with the problems.

Customer: replied 1 month ago.
I have changed every fuse that I can find
Customer: replied 1 month ago.
Is there a relay i should be looking at?
Fuse box issue?
Expert:  david craig replied 1 month ago.

what about the efi relay? lets see if we're getting power to it

Customer: replied 1 month ago.
can you please send me the correct fuse box, the one you sent earlier does not match.
Expert:  david craig replied 1 month ago.

you have a 2000 rx 300 correct?

Customer: replied 1 month ago.
Expert:  david craig replied 1 month ago.

they are correct

Customer: replied 1 month ago.
Sorry to be a pain, is there two relays for the EFI?

Related Lexus Questions