How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask scionking Your Own Question
scionking
scionking, MASTER CERTIFIED
Category: Lexus
Satisfied Customers: 469
Experience:  5 YRS EXP. ASE MASTER CERTIFIED/ TOYOTA MASTER CERTIFIED
26789525
Type Your Lexus Question Here...
scionking is online now
A new question is answered every 9 seconds

SC430 - 2008 - Lexus Stock Navigation Unit displays --

Customer Question

SC430 - 2008 - Lexus
Stock Navigation Unit displays -- "check the system" -- everything else on screen works, touch, can go into settings (for screen), as well make phone calls from that screen.. but nothing else works just displays "check the system"
Do I need a new Nav ECU? or..
Submitted: 7 months ago.
Category: Lexus
Expert:  scionking replied 7 months ago.

Hello and welcome to Just Answer, my name is ***** ***** I start by asking some questions?

Customer: replied 7 months ago.
that's fine.. what questions do you have?
Expert:  scionking replied 7 months ago.

Did any thing happen leading up to this? Dead battery, jump start, any work done to the car recently?

Customer: replied 7 months ago.
New stereo installation, ripped out front dash, ripped out trunk.. it was working fine with radio for a week afterwards, one day, turned car on, opened nav screen, and "check the system"
Customer: replied 7 months ago.
Tried swapping the DVD's (older and existing) still same error, tried almost everything except a new Nav ECU unit.
Expert:  scionking replied 7 months ago.

Are you able to get into diagnostic mode with the screen?

Customer: replied 7 months ago.
Not sure which diag mode you're speaking of, I am able to get to the Display Settings (brightness/color/contrast) as well access the Phone Menu options (by pressing the keys on the MFD and the steering wheels) to display on the nav screen.Just unable to do anything else on Nav Screen i.e get into NAV mode..Is there a different sequence you have to get into your specific diag mode?
Expert:  scionking replied 7 months ago.

Step 1 Press The Menu button
Step 2 Press the Volume button
Step 3 Press The Upper Left of the screen
Step 4 Press The Lower Left of the screen
Step 5 Press Upper Left of the screen again
Step 6 Press Lower Left of the screen again
Step 7 Press and hold the Override Button until system beeps
Step 8 Press Back Button in upper right corner

Customer: replied 7 months ago.
Will try that now..
Customer: replied 7 months ago.
There is no volume button.. and I tried it and nothing.. just so you can see the error.https://www.youtube.com/watch?v=dMN1FkxU7CE
Expert:  scionking replied 7 months ago.

Let me do a little more research on this.....

Customer: replied 7 months ago.
I have obd / tech stream as well in case you wanted any outputs from that. I haven't seen any errors pop up with that yet.I'm not car expert, but I can diy a lot on my bmw/benz/lexus's this error was a strange one..
Expert:  scionking replied 7 months ago.

Yes that appears to be like the Nav is not powered on? Have you checked fuses, I believe there is 5 fuse panels in the car. Just want to cover the basics first.

Customer: replied 7 months ago.
The Nav unit has power to it (I can eject/insert discs) -- I have also checked all fuses. I uploaded another video i can get into diaghttps://www.youtube.com/watch?v=dOREFw-nF2Q
Expert:  scionking replied 7 months ago.

You checked the fuse panel on the passenger side near the glove box area? There is a TV fuse and Radio # 2 fuse. You also want to check AM1 fuse on drivers side near feet. The unit can still get power.

Expert:  scionking replied 7 months ago.

Either something is powered off, or it has no communication to the network, on the initial screen of your video it should have showed a result from each component test but it is blank.

Customer: replied 7 months ago.
It takes a while for the component test to complete, I didn't show that, but it doesn't show Nav or radio communication.I'll recheck all fuses after I finish work.
Expert:  scionking replied 7 months ago.

Does it give a code once complete? Should be either OK, EXCH, CHEk, NCON, Old, or NRES

Expert:  scionking replied 7 months ago.

Just checking in to see if you still need assistance with this? If I have answered your question please be so kind as to accept my answer and rate the level of service provided. If you have any follow up questions I'd be more than happy to help. Thank you for using Just Answer

Expert:  scionking replied 7 months ago.

Just checking in to see if you still need assistance with this? If I have answered your question please be so kind as to accept my answer and rate the level of service provided. If you have any follow up questions I'd be more than happy to help. Thank you for using Just Answer.

Related Lexus Questions