How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Eric Your Own Question
Eric
Eric, Automotive Repair Shop Manager
Category: Lexus
Satisfied Customers: 31095
Experience:  20+ yrs. experience as repair shop manager and technician.
3195632
Type Your Lexus Question Here...
Eric is online now
A new question is answered every 9 seconds

I replaced the 02 sensor rx330 bank 1 sensor to but i have a

Customer Question

Hi, I replaced the 02 sensor for my rx330 bank 1 sensor to but i have a o2 sensor not ready showing up when getting the car inspected.
JA: What happens when you step on the gas? Do you notice a rough idle?
Customer: Yes, it isn't as strong as it used to be
JA: What is the model/year of your Lexus?
Customer: 2004 rx330
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: I have replaced the o2 myself
JA: Anything else you think the mechanic should know?
Customer: No
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Lexus Mechanic about your situation and then connect you two.
Submitted: 10 months ago.
Category: Lexus
Customer: replied 10 months ago.
Car will not pass inspection due to o2 sensor not showing up ready. I also own another one exactly the same model. This one seems to not accelerate as quick and seems weaker. I assume there is an issue some where with the o2. AutoZones mentioned it was a 02 sensor issue. I replaced it and the check engine went away, but did not run the same. It also will not pass inspection now. It is a Denso brand and I also used a voltage meter to see if the sensor is still good. It shows that voltage runs through it when I test the negative lines. Thanks
Expert:  Eric replied 10 months ago.

HI,

Ok, I need to know which sensor you replaced. The one in the exhaust manifold facing the radiator(facing the front of vehicle) or the one in the exhaust manifold facing the firewall(facing rear of vehicle)

Customer: replied 10 months ago.
The one under the driver seat.
Customer: replied 10 months ago.
I replaced this one. http://cimg0.ibsrv.net/gimg/www.clublexus.com-vbulletin/2000x1504/80-underthecar_7440e484267c558a97023b49b305d8d92ee15ff7.jpg
Expert:  Eric replied 10 months ago.

HI,

Ok, that is the correct one for Bank1 Sensor2. I asked because Toyota/Lexus are backwards to 99% of vehicles on the market as far as bank placement numbers

What was the exact fault code number?

Customer: replied 10 months ago.
That is the weird thing. The check engine light is off. No code is showing up. However, I know it doesn't run the same. When pressing on the gas it doesn't accelerate like it used to. I have no idea what else could be wrong with it.
Customer: replied 10 months ago.
Also, when I get it inspected their machine says the o2 sensor isn't ready. I drove it for over 5k miles and it still hasn't cleared or rested.
Customer: replied 10 months ago.
reset
Customer: replied 10 months ago.
Before I replaced it the code showed up for me to replace this sensor.
Expert:  Eric replied 10 months ago.

HI,

Ok, what the mechanic means is that the emission monitor for the O2 sensors has not set to readiness state. This requires a specific condition based drive cycle to perform. Give me a moment to upload it for you

Customer: replied 10 months ago.
Correct. He said that it usually will be ready after 50 miles. In this case it won't get in a ready state.
Customer: replied 10 months ago.
I think 1k miles would do it though. City and highway miles.
Expert:  Eric replied 10 months ago.

HI,

I never understand why the emission testers tell people to just drive it X amount of miles. It doesnt work that way. A specific condition based drive cycle must be performed. Below is the drive cycle Lexus states to be done

2004 Lexus Truck RX 330 FWD V6-3.3L (3MZ-FE)

Save Article

READINESS MONITOR DRIVE PATTERN

OXYGEN/AIR FUEL RATIO SENSOR MONITOR (FRONT A/F SENSOR AND REAR O2S SYSTEM)

a. Preconditions
The monitor will not run unless:
MIL is OFF

Cold Soak for at least 8hrs

Fuel tank between 1/4 tank and 3/4 tank

b. Drive Pattern
1. Connect the OBD II scan tool to DLC3 to check monitor status and preconditions (refer to step "a").
2. Start the engine and it to idle for 2 minutes or more.
3. Drive the vehicle at 40 to 70 mph (64 to 112 km/h) or more for at least 150 seconds.
4. Stop the vehicle and allow the engine to idle for 10 seconds or more.
5. Drive the vehicle at 25 mph (40 km/h) or more for at least 40 seconds.
6. Stop the vehicle and allow the engine to idle for 10 seconds or more.
7. Perform steps (5) and (6) ten times.
8. Check the status of the readiness monitor on the scan tool display. If readiness status did not switch to complete, ensure preconditions are met, turn ignition off and then repeat steps (1) through (6).

OXYGEN/ A/F SENSOR HEATER MONITOR

a. Preconditions
The monitor will not run unless:
MIL is OFF

Cold Soak for at least 8hrs

Fuel tank between 1/4 tank and 3/4 tank

b. Drive Pattern
1. Connect the OBD II scan tool to DLC3 to check monitor status and preconditions (refer to step "a").
2. Start the engine and allow it to idle for 500 second or more.
3. Drive the vehicle at 25 mph (40 km/h) or more for at least 2 minutes.
4. Check the status of the readiness monitor on the scan tool display. If readiness status did not switch to complete, ensure preconditions are met, turn ignition off and then repeat steps (2) and (3).

Customer: replied 10 months ago.
Just to clarify. It has to be done in these exact steps?
Customer: replied 10 months ago.
Can you also tell me what The monitor will not run unless:
MIL is OFF
Expert:  Eric replied 10 months ago.

HI,

Yes, it has to be done in those exact steps. You can even put it up on jackstands and run it so that you can ensure doing it exactly as stated.

MIL is OFF just means that the check engine light is off

Cold soak for at least 8hrs means that the engine has been off for at least 8hrs before doing the drive cycle

Please remember to rate service using the rating page so that I may receive credit. Thanks

If for any reason, you can't rate my answer OKAY, GOOD, or EXCELLENT today.
Please reply and let me know why, so I can help more/better.
All follow up responses are FREE, after completing the required rating

Please note that if you have a subscription service, you still are required to rate service, however you are not charged again. This is just so that your expert is credited for their time and services.Thank you.

Expert:  Eric replied 10 months ago.

I noticed we have not yet resolved your concern you asked about. I would sure appreciate it if you would reply so I can offer my skills and knowledge and repair guide access to help as best I can.

~Do you still need more help?
~Confused by my info request or answer?
~Need more time?
~Confused on how the site works?
~Need more detail or a different explanation?

If the answer is YES to any of these just press reply and lets work on this concern some more.

If you have new questions now or in the future please do not hesitate to ask them. If you would like me to assist you. Just bookmark this page so you can access my profile easy and post a new question from the question box on my profile page.

Please remember to rate service using the rating page so that I may receive credit. Thanks

Please note that if you have a subscription service, you still are required to rate service, however you are not charged again. This is just so that your expert is credited for their time and services. Thank you.

Expert:  Eric replied 10 months ago.

I noticed we have not yet resolved your concern you asked about. I would sure appreciate it if you would reply so I can offer my skills and knowledge and repair guide access to help as best I can.

~Do you still need more help?
~Confused by my info request or answer?
~Need more time?
~Confused on how the site works?
~Need more detail or a different explanation?

If the answer is YES to any of these just press reply and lets work on this concern some more.

If you have new questions now or in the future please do not hesitate to ask them. If you would like me to assist you. Just bookmark this page so you can access my profile easy and post a new question from the question box on my profile page.

Please remember to rate service using the rating page so that I may receive credit. Thanks

Please note that if you have a subscription service, you still are required to rate service, however you are not charged again. This is just so that your expert is credited for their time and services. Thank you.