How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Skyvisions Your Own Question
Skyvisions
Skyvisions, ASE Certified Technician
Category: Lexus
Satisfied Customers: 14357
Experience:  Lexus Expert
8257649
Type Your Lexus Question Here...
Skyvisions is online now
A new question is answered every 9 seconds

2001 is300...had CEL plus flashing trac off. replaced

Customer Question

2001 is300...had CEL plus flashing trac off. replaced exhaust manifold and o2 sensors. drove well for a while now back with code for bank 1 sensor 1 o2 and CEL and flashing trac off light. runs normal sometimes then throttle drops out and it is basically in limp mode...hard shifts and must press accelerator all the way until mechanical linkage is engaged.
Submitted: 1 year ago.
Category: Lexus
Expert:  Skyvisions replied 1 year ago.

Do you have the specific code numbers and has there ever been any other code in the engine control computer besides the oxygen sensor code?

Customer: replied 1 year ago.
sorry for the delay...just got my code reader. it's showing P0135 for B1S1 heater malfunction. i have all new O2 sensors so what else can i check here? am i to be concerned with ECU problems at this point? also showing P1120 and P1121 which i've cleared before and they don't come back immediately. i think they are displaying after running for too long w/ P0135 and that's why it does into limp mode??
Expert:  Skyvisions replied 1 year ago.

The P1120 and P1121 should have anything to do with the oxygen sensor. That strictly a code setting because of a malfunction in the accelerator pedal position sensor circuit. It could be an intermittent problem. That's what causes it to go into limp mode when it doesn't see the proper input from that sensor on the throttle body. Did you replace the oxygen sensor for bank one sensor one with a new DENSO brand sensor and does your code reader allow you to read live data as you can monitor the voltage output of the sensor? At the engine side of the harness to B1S1 What is the voltage at the Black wire with the red tracer with the key on? Then check the green wire with the key on. What is that voltage on the light green wire with the car running?

Customer: replied 1 year ago.
Thanks Skyvisions! I checked and we're reading ~12VDC b/w the black/red trace wire and the battery ground (key all the way on but car not running and O2 sensor disconnected). I get no voltage b/w the green/black trace wire and the battery negative terminal. I tried w/ the car running and the key all the way on but car not running.I don't know much about the code reader...borrowed it from a friend. It is a Innova Equus 3030.The O2 sensor was from Advance Auto and it wasn't a Denso. But I replaced B1S1, B2S2, and B2S1 with the same style. I measured the resistance on the sensor itself (pins that connect to the black/red trace and green/black trace) and I get ~10 ohms. That was after I turned the car of...it had been running about 5 minutes. The other 2 pins read no resistance, either on the sensor or the chassis connector (one wire appears light brown and one wire appears white).Now what?
Expert:  Skyvisions replied 1 year ago.

The color coding of the wires going to the sensor that you just explained being the green with black tracer is for bank one sensor two. That would set a P0141 code you need to find bank one sensor one and the wire color coding should be as I described. Then check the voltages as I described on the R/B wire and the light green wire.

Expert:  Skyvisions replied 1 year ago.

Just checking back with you to see if you got the last reply that I gave you that the sensor you were checking was the wrong one. Were you able to test the voltage on the correct sensor on the color-coded wiring that I gave you?

Related Lexus Questions