How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tom Your Own Question
Tom
Tom, ASE Certified Technician
Category: Lexus
Satisfied Customers: 25927
Experience:  ASE Certified Master Technician qualified to work on all makes and models.
3827149
Type Your Lexus Question Here...
Tom is online now
A new question is answered every 9 seconds

Lexus RX330: My 2005 RX330 a/c codes are 24 and 32. The passanger

This answer was rated:

My 2005 RX330 a/c codes are 24 and 32. The passanger side is cooling but the drivers side isn't. Will replacing the relay in the fuse box under the hood fix both problems?
Hi I’m Tom and I’m here to assist you with your issue today. Before I get you a fully researched answer, I have to ask you a couple preliminary questions.What would you actually like to know I would be glad to help.Does the a/c light flash also ?
Customer: replied 3 years ago.
No, not unless I go through water.
OK thats telling you there is an issue with the a/c compressor clutch relay in the under hood fuse box was this checked?
Customer: replied 3 years ago.
The clutch is fine also. I just read on this site that for code 24 you need to replace the relay.
Yes thats what I was getting at you need to replace the compressor clutch relay with the updated relay from the dealer and this will fix your issue .This is what needs to be done to fix this issue .Remember that I'm here if you need any further assistance just let me know it will be for no further charge. Hoped this helped.Please rate excellent service so I can get Credit for my help thanks. Bonuses greatly appreciated.
Tom and 2 other Lexus Specialists are ready to help you
Customer: replied 3 years ago.

Ok, I still need some help. I am not sure that I have found the magnetic clutch relay. I thought it was in J/B#2. Under the cover labeled Relays. This is behind the fuses which is behind the battery. The cover has the information on the relays, but none of them are labeled anything like mg/cl. There are four of them. Three look the same and the starter looks different. The three are horn, EFI Main and A/F. I thought it might be A/F so I swapped the A/F and the Horn relays and there was no change.

Customer: replied 3 years ago.
I have read that there are models that don't have the clutch relay. I think mine doesn't.
The location is in the Fuse box as MG CLT Rly 5th one down. If that's not the issue then it can be code 11and the that problem is the connector to the temperature sensor is not functioning. Clean up the connector with some contact cleaner, plug it back to the sensor. Let me know what you find.
Customer: replied 3 years ago.

For some reason my model RX330 isn't like others (see above comments). There is not label anything like MG CLT. That's my problem. The relay box (part of J/B 2) is behind the fuse box and under the brake fluid. I had to remove the brake fluid reservoir in order to get to it.


 


It sounds like it's not a normal configuration or maybe I am missing something. I can take a pic of both the fuse lid and the relay lid if it helps.

Yes that would help if you could.
Customer: replied 3 years ago.

When I insert a pic I get access denied.

Customer: replied 3 years ago.

I put them in a google drive folder. See if you can access them from the link.


 


https://drive.google.com/folderview?id=0B_OO1uTTi7bPZ0U4TEVQLUU3eVk&usp=sharing


 

Try to swapping the relay labeled fan 2 and see if that makes a difference. Let me know it for not it's going to be the connection to the ambient temperature sensor or the sensor itself.
Customer: replied 3 years ago.

There is no relay in either fan 2 or BRK above it.

Ok there should be a relay for fan2 did anyone remove that recently ?
Customer: replied 3 years ago.

Very weird. As far as I know no one has touched it. You have to remove the brake reservoir to get to it.. Besides, there is no electrical receptacle for the blade connectors of the relay in that position. Take a look at pic "fuse box 1"

Ok have you checked for any other codes?
Customer: replied 3 years ago.

I did another a/c check and now the only code is 32. 24 isn't displayed now. And still the passenger side cools and the driver side does not.

OK that code is usually due to a low refrigerant level what are the high and low side pressures?
Customer: replied 3 years ago.

I will try and find out, I had a mechanic at pep boys check it.


 


What should it be?


Is it possible when one side is cooling and one isn't and the problem is refrigerant level?

Customer: replied 3 years ago.
Got it. 28 and 225
Oknthats with the system on correct?
Customer: replied 3 years ago.
Yes
Customer: replied 3 years ago.
Also, drive to dinner. It started cooling on the passengers side also. Checked the codes again and they were 24 and 32. Don't know how long it will work.
Ok this is a low refrigerant issue which the refrigerant is slightly low, low side should be 34 at least or a faulty passenger side drivers air/mix motor.
Customer: replied 3 years ago.

Ok, I will add refrigerant and see if that hopefully fixes it. Thanks.


 


 

Anytime have a great weekend!

Related Lexus Questions