How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tom Your Own Question
Tom
Tom, ASE Certified Technician
Category: Lexus
Satisfied Customers: 25944
Experience:  ASE Certified Master Technician qualified to work on all makes and models.
3827149
Type Your Lexus Question Here...
Tom is online now
A new question is answered every 9 seconds

Lexus ES330: how to change the back three spark plugs on 2005

Resolved Question:

how to change the back three spark plugs on 2005 Lexes 330 ES.
Do you have to remove intake plemen and sugestions on how to remove
the bolts on the back of plemen? support bracket
Submitted: 4 years ago.
Category: Lexus
Expert:  Tom replied 4 years ago.
Its the same process as the 300. This will show you exactly how it's done.
ClickHere
Hoped this helped.Positive feedback and bonuses greatly appreciated .
Expert:  Tom replied 4 years ago.
Did you need anything else?
Customer: replied 4 years ago.

the 2005 es has a electronic thortle body so when I remove the TB is wasn't

like on a older rx 300. I got car back together and runs but the check engine

light is on. Check the hose connection only see a hose fit on the rear valve cover

that does not have a hose. I am not sure if there should be one there cannot seem to

a loose hose. any susjestions.

Expert:  Tom replied 4 years ago.
Is the vehicle running ok? If you disconnect the battery to clear the engine light does the light clear?
Customer: replied 4 years ago.

the engine is missing at idle speed and seem to run smooth at 2000 RPM>

the check engine light does not clear if you disconnent battery. I think I disconnented

hoses and unbolted intake manifold and throlle body may have leak or mass air sencor is not working.

Expert:  Tom replied 4 years ago.
Ok that's the issue then . You will need to go over your work and reattach the vacuum line and make sure the mass air flow sensor is connected. Once you go over your work you will find the cause . Hoped this helped. Positive feedback and bonuses greatly appreciated.
Tom and 3 other Lexus Specialists are ready to help you

Related Lexus Questions