How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kiatech Your Own Question
Kiatech, Kia Master Technician
Category: Kia
Satisfied Customers: 210
Experience:  30+ years experience,ASE certified,KIA certified Master Technician,Ford factory trained
Type Your Kia Question Here...
Kiatech is online now
A new question is answered every 9 seconds

I just installed a used 1. 5 engine in my 2001 Rio. The

Customer Question

I just installed a used 1. 5 engine in my 2001 Rio. The engine starts right up but runs only few seconds then shuts off. It will start right back up but again only run few seconds. Same thing over and over. I have a check engine light on so I bought a scanner for OBD2 but can't pull code and will not clear code.
Submitted: 13 days ago.
Category: Kia
Expert:  Chad Farhat replied 13 days ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Expert:  Chad Farhat replied 13 days ago.

Hey how are you

it sounds like the alarm is triggered on .

was the harness connector identical to the new engine

do you the ECM off the car you got engine from

you will need A KIA scanner or equivalent to reprogram & retrieve fault codes from the anti theft module , the code reader you have probably only read engine codes , does it hook up and says no DTC or it tells no Communication?

the engine cranks & starts and then computer don't recognize the key or a malfunctions in on of the alarm sensors , it thinks somebody stealing it and cut fuel pump .

You Can Try Master Reset If you have not already

Master reset Procedure

1- Disconnect Battery Cables ( Negative & Positive Cables )

2- Hold cables Together for 60 secs ,then let go

3- Wait 15 minute

4- Make sure all doors are closed

5- Reconnect battery Cables

6- Lock & unlock the vehicles using the key from driver door side (if you have a key fob with no blade key, just lock & unlock using the key fob buttons)

7- Enter the vehicle and attempt to start

Please let me know if that works for you

Thank You

Chad Farhat

ASE Certified Technician

Customer: replied 13 days ago.
I used the engine wiring harness that came off the engine I pulled out. Its the harness that came in my car. Its my cars ECM. Only thing I changed was the motor. All my wiring connectors hooked right up.
Expert:  Chad Farhat replied 13 days ago.

is there a red led security light flashing on dash while starting it or running for these few seconds?

Related Kia Questions