How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kiatech Your Own Question
Kiatech
Kiatech, Kia Master Technician
Category: Kia
Satisfied Customers: 210
Experience:  30+ years experience,ASE certified,KIA certified Master Technician,Ford factory trained
32162675
Type Your Kia Question Here...
Kiatech is online now
A new question is answered every 9 seconds

I have a 2015 cerato that stalls when ever i accelerate,

Customer Question

hi there
JA: Hi. How can we be of help?
Customer: I have a 2015 cerato that stalls when ever i accelerate
JA: Is the check engine light on? Does the car stall at idle or when driving?
Customer: nop, no check engine no codes no nothing. it has a rough idling and when i accelerate it stall or you can hear noise from the intake side
JA: What is the model of your '15 Kia?
Customer: standered 1.6ltr
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: I'm a technician and I have diagnostic scan and everything, the owner said that he cleaned the throttle, injectors, changed the spark plugs, fuel filter
JA: Anything else you think the mechanic should know?
Customer: hmmm, like what? i hope you excuse my english. its not my first language
Submitted: 7 months ago.
Category: Kia
Customer: replied 7 months ago.
The car seems like its lacking fuel, when ever the throttle is fully opened where more air is coming in, the engine starts to stall. If it didn't, the rpm won't go more than 2000rpm, the car has around 50000km on it and everything seems oke, wiring, fuses,no DTC. But I noticed something about one of the PID's, the "lambda something" its not stable and it fluctuate between -20% up to 20%. I tried searching for SFT and LFT but I couldn't find it.
Expert:  david craig replied 7 months ago.

Hi im David.....has the vehicle been checked for vacuum leaks?

Customer: replied 7 months ago.
I checked the small hoses on top of the intake manifold, around the throttle, it doesn't seems like there is any leak. Maybe I over looked some things, can you tell me where to check.
Expert:  david craig replied 7 months ago.

around the base of the intake, at the brake booster where the hose attaches to it and on the back of the intake.

Customer: replied 7 months ago.
I covered all that. everything is bling bling
Expert:  david craig replied 7 months ago.

ok. have you cleaned the mass air flow sensor? tested fuel pressure? pulled the vac hose off the fpr and checked for the presence of fuel on it?

Customer: replied 7 months ago.
I'v cleaned the MAF sensor, but didn't check the fuel pressure nor checking for fuel in the vac hose.
Expert:  david craig replied 7 months ago.

try that. if fuel pressure is good and no fuel present at fpr hose, then we will go from there.

Customer: replied 7 months ago.
oke
Expert:  david craig replied 7 months ago.

any progress?